summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 11:42:14 +0800
committerSukanka2022-06-06 11:42:14 +0800
commite5d666d351c68a587c18eb5ee6014fe416cec0bd (patch)
tree6fa092d8bf1e701107d652c4d2140413631f3c52
downloadaur-e5d666d351c68a587c18eb5ee6014fe416cec0bd.tar.gz
add r-graphat
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7fcd9bb4eca0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = r-graphat
+ pkgdesc = Graph Theoretic Association Tests
+ pkgver = 1.68.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/GraphAT
+ arch = any
+ license = LGPL
+ depends = r
+ depends = r-graph
+ depends = r-mcmcpack
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/GraphAT_1.68.0.tar.gz
+ sha256sums = c1e93243abe1dcf75b247224f87ae65377256bf7c45c5ae1c21ce7eba667b8e8
+
+pkgname = r-graphat
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..39d0fcde92b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=GraphAT
+_pkgver=1.68.0
+pkgname=r-${_pkgname,,}
+pkgver=1.68.0
+pkgrel=1
+pkgdesc='Graph Theoretic Association Tests'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('LGPL')
+depends=(
+ r
+ r-graph
+ r-mcmcpack
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('c1e93243abe1dcf75b247224f87ae65377256bf7c45c5ae1c21ce7eba667b8e8')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: