summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 12:06:22 +0800
committerSukanka2022-06-06 12:06:22 +0800
commit0be1a8ecad4820749dbd24c22c1657c74c140f00 (patch)
tree7f5a96b55819a35025eada2279e504692e6c00c5
downloadaur-0be1a8ecad4820749dbd24c22c1657c74c140f00.tar.gz
add r-hdtd
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..902c0e2550ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = r-hdtd
+ pkgdesc = Statistical Inference about the Mean Matrix and the Covariance Matrices in High-Dimensional Transposable Data (HDTD)
+ pkgver = 1.30.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/HDTD
+ arch = x86_64
+ license = GPL
+ depends = r
+ depends = r-rcpp
+ depends = r-rcpparmadillo
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/HDTD_1.30.0.tar.gz
+ sha256sums = f88e310de7c5223aa11b94fc28c91faaebe96c5a3a0965bb697745ca71e88b20
+
+pkgname = r-hdtd
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f27be6788e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=HDTD
+_pkgver=1.30.0
+pkgname=r-${_pkgname,,}
+pkgver=1.30.0
+pkgrel=1
+pkgdesc='Statistical Inference about the Mean Matrix and the Covariance Matrices in High-Dimensional Transposable Data (HDTD)'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-rcpp
+ r-rcpparmadillo
+)
+optdepends=(
+ r-knitr
+ r-rmarkdown
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('f88e310de7c5223aa11b94fc28c91faaebe96c5a3a0965bb697745ca71e88b20')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: