summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-07 00:25:12 +0800
committerSukanka2022-06-07 00:25:12 +0800
commit51db9f3a87896041f9f9704446ee0a806b208449 (patch)
tree2410fcae7db4e3912277265bd1caa2199daa1725
downloadaur-51db9f3a87896041f9f9704446ee0a806b208449.tar.gz
add r-heplots
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD40
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb88cec27bd2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = r-heplots
+ pkgdesc = Visualizing Hypothesis Tests in Multivariate Linear Models
+ pkgver = 1.3.9
+ pkgrel = 4
+ url = https://cran.r-project.org/package=heplots
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-car
+ optdepends = r-animation
+ optdepends = r-candisc
+ optdepends = r-corrgram
+ optdepends = r-effects
+ optdepends = r-gplots
+ optdepends = r-lattice
+ optdepends = r-mvinfluence
+ optdepends = r-nlme
+ optdepends = r-reshape
+ optdepends = r-reshape2
+ optdepends = r-rgl
+ source = https://cran.r-project.org/src/contrib/heplots_1.3-9.tar.gz
+ sha256sums = 9d19b3941d8239c2d78b2a898c350faac5b42632fa8421450778df1c1ef29225
+
+pkgname = r-heplots
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5afc680973e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: sukanka <su975853527@gmail.com>
+
+_pkgname=heplots
+_pkgver=1.3-9
+pkgname=r-${_pkgname,,}
+pkgver=1.3.9
+pkgrel=4
+pkgdesc='Visualizing Hypothesis Tests in Multivariate Linear Models'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-car
+)
+optdepends=(
+ r-animation
+ r-candisc
+ r-corrgram
+ r-effects
+ r-gplots
+ r-lattice
+ r-mvinfluence
+ r-nlme
+ r-reshape
+ r-reshape2
+ r-rgl
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('9d19b3941d8239c2d78b2a898c350faac5b42632fa8421450778df1c1ef29225')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: