summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-06-21 00:10:10 +0000
committerBioArchLinuxBot2023-06-21 00:10:10 +0000
commit5828d36867bea46aed34f069acd8f8b9183a63b6 (patch)
treeebf4163c6651d92a9cb9289f569e6e62ded88351
parentbbb32cf3a03ee21ea80485b0bf29f227739e7993 (diff)
downloadaur-5828d36867bea46aed34f069acd8f8b9183a63b6.tar.gz
[lilac] updated to 1.28.3-3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD43
2 files changed, 28 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c1228bdf717..4882c398fa6c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = r-hexbin
pkgdesc = Hexagonal Binning Routines
pkgver = 1.28.3
- pkgrel = 1
+ pkgrel = 3
url = https://cran.r-project.org/package=hexbin
- arch = i686
arch = x86_64
license = GPL2
makedepends = gcc-fortran
depends = r
- optdepends = r-marray
optdepends = r-affy
optdepends = r-biobase
- optdepends = r-limma
optdepends = r-knitr
+ optdepends = r-limma
+ optdepends = r-marray
source = https://cran.r-project.org/src/contrib/hexbin_1.28.3.tar.gz
+ md5sums = d0035d06e66b9229586590b03d258288
sha256sums = 0eb33511c1a4ff29dda8b89fee420ea7041033f981c7f16484c9f504d749de5f
pkgname = r-hexbin
diff --git a/PKGBUILD b/PKGBUILD
index c23b4ed51213..565f87088251 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,38 @@
# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
-_cranname=hexbin
-_cranver=1.28.3
-pkgname=r-${_cranname,,}
-pkgver=${_cranver//[:-]/.}
-pkgrel=1
+_pkgname=hexbin
+_pkgver=1.28.3
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//[:-]/.}
+pkgrel=3
pkgdesc="Hexagonal Binning Routines"
-arch=(i686 x86_64)
-url="https://cran.r-project.org/package=${_cranname}"
+arch=(x86_64)
+url="https://cran.r-project.org/package=${_pkgname}"
license=(GPL2)
-depends=(r)
-makedepends=(gcc-fortran)
+depends=(
+ r
+)
+makedepends=(
+ gcc-fortran
+)
optdepends=(
- r-marray
- r-affy
- r-biobase
- r-limma
- r-knitr
+ r-affy
+ r-biobase
+ r-knitr
+ r-limma
+ r-marray
)
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('d0035d06e66b9229586590b03d258288')
sha256sums=('0eb33511c1a4ff29dda8b89fee420ea7041033f981c7f16484c9f504d749de5f')
build() {
mkdir -p build
- R CMD INSTALL "${_cranname}" -l "${srcdir}/build"
+ R CMD INSTALL "$_pkgname" -l build
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
-
- cp -a --no-preserve=ownership "build/${_cranname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}