summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-02-29 00:03:28 +0000
committerBioArchLinuxBot2024-02-29 00:03:28 +0000
commit56370cbcea514d43fb76e5246615fce524835528 (patch)
treec26d7292f1d718b4c8ac112da11272f8468e1459
parent77c8de5e42e55a170f9dc011aee69a14c74d5072 (diff)
downloadaur-56370cbcea514d43fb76e5246615fce524835528.tar.gz
[lilac] updated to 0.8.1-7
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD23
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d18af2b169a8..8207b9b58bf6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = r-hgnchelper
pkgdesc = Identify and Correct Invalid HGNC Human Gene Symbols and MGI Mouse Gene Symbols
pkgver = 0.8.1
- pkgrel = 4
+ pkgrel = 7
url = https://cran.r-project.org/package=HGNChelper
arch = any
- license = GPL
+ license = GPL-2.0-or-later
depends = r
optdepends = r-knitr
optdepends = r-rmarkdown
optdepends = r-testthat
source = https://cran.r-project.org/src/contrib/HGNChelper_0.8.1.tar.gz
- sha256sums = aa3f0b3a8691ed93d63bec8f36d2954c6fcfd0b8b3efc705379248544c999363
+ md5sums = 45d4542ac3250350b96c3c9506acffcc
+ b2sums = d32cefe15711f65345af36f085455d590a696f676f786f02b5c10caae101be3803f8d4852a7bca5a67cc6fdc81d6be0f4bf18b7d69ab7dcb68efdd9095d25dde
pkgname = r-hgnchelper
diff --git a/PKGBUILD b/PKGBUILD
index f4e03f3c3698..3a467c8cfe3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
_pkgname=HGNChelper
_pkgver=0.8.1
pkgname=r-${_pkgname,,}
-pkgver=0.8.1
-pkgrel=4
-pkgdesc='Identify and Correct Invalid HGNC Human Gene Symbols and MGI Mouse Gene Symbols'
-arch=('any')
-url="https://cran.r-project.org/package=${_pkgname}"
-license=('GPL')
+pkgver=${_pkgver//-/.}
+pkgrel=7
+pkgdesc="Identify and Correct Invalid HGNC Human Gene Symbols and MGI Mouse Gene Symbols"
+arch=(any)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('GPL-2.0-or-later')
depends=(
r
)
@@ -18,14 +18,15 @@ optdepends=(
r-testthat
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('aa3f0b3a8691ed93d63bec8f36d2954c6fcfd0b8b3efc705379248544c999363')
+md5sums=('45d4542ac3250350b96c3c9506acffcc')
+b2sums=('d32cefe15711f65345af36f085455d590a696f676f786f02b5c10caae101be3803f8d4852a7bca5a67cc6fdc81d6be0f4bf18b7d69ab7dcb68efdd9095d25dde')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: