summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-10-08 08:16:05 +0300
committerPekka Ristola2023-10-08 08:16:05 +0300
commit07530593a31abeb79ead70f719f7d328729360ad (patch)
tree58856579d84ab859a47b0384e9f9d9601f91d30f
downloadaur-07530593a31abeb79ead70f719f7d328729360ad.tar.gz
Version 2.18.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dad5c584d4d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = r-hgu95av2cdf
+ pkgdesc = hgu95av2cdf
+ pkgver = 2.18.0
+ pkgrel = 3
+ url = https://bioconductor.org/packages/hgu95av2cdf
+ arch = any
+ license = LGPL
+ depends = r-annotationdbi
+ source = https://bioconductor.org/packages/release/data/annotation/src/contrib/hgu95av2cdf_2.18.0.tar.gz
+ md5sums = 026bae2f76433593f75ca6c79bc9a9d0
+ sha256sums = d449a06a2f55a5a1f942710c8da2a37a81e20342b6e600669df94ecb55f1e1fe
+
+pkgname = r-hgu95av2cdf
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3553ae0d6ec8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: sukanka <su975853527@gmail.com>
+
+_pkgname=hgu95av2cdf
+_pkgver=2.18.0
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=3
+pkgdesc="hgu95av2cdf"
+arch=(any)
+url="https://bioconductor.org/packages/${_pkgname}"
+license=(LGPL)
+depends=(
+ r-annotationdbi
+)
+source=("https://bioconductor.org/packages/release/data/annotation/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('026bae2f76433593f75ca6c79bc9a9d0')
+sha256sums=('d449a06a2f55a5a1f942710c8da2a37a81e20342b6e600669df94ecb55f1e1fe')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+}