summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 12:17:46 +0800
committerSukanka2022-06-06 12:17:46 +0800
commitf016625883af2762f5cc44a6768efe20ad7c2077 (patch)
treee87f681b2abaf46e8d2d77de1b46ba1325c5d67f
downloadaur-f016625883af2762f5cc44a6768efe20ad7c2077.tar.gz
add r-hilbertvisgui
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1561e5daf766
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = r-hilbertvisgui
+ pkgdesc = HilbertVisGUI
+ pkgver = 1.54.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/HilbertVisGUI
+ arch = x86_64
+ license = GPL
+ depends = r
+ depends = r-hilbertvis
+ depends = gtkmm
+ optdepends = r-iranges
+ optdepends = r-lattice
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/HilbertVisGUI_1.54.0.tar.gz
+ sha256sums = b1d968bfd89794bd290345c46c3c5b07da158196fd427a6080eea894a04aa9a7
+
+pkgname = r-hilbertvisgui
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52ce49132450
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# system requirements: gtkmm-2.4, GNU make
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=HilbertVisGUI
+_pkgver=1.54.0
+pkgname=r-${_pkgname,,}
+pkgver=1.54.0
+pkgrel=1
+pkgdesc='HilbertVisGUI'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-hilbertvis
+ gtkmm
+)
+optdepends=(
+ r-iranges
+ r-lattice
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('b1d968bfd89794bd290345c46c3c5b07da158196fd427a6080eea894a04aa9a7')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: