summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 12:40:26 +0800
committerSukanka2022-06-06 12:40:26 +0800
commitc577d1b0d18bc5ae33bd908e9ae5e7bb1dc2951c (patch)
tree1b5ad2c42c9c7110a1cc3787227d5d0773373a73
downloadaur-c577d1b0d18bc5ae33bd908e9ae5e7bb1dc2951c.tar.gz
add r-icobra
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD43
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c6bb9aa671c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = r-icobra
+ pkgdesc = Comparison and Visualization of Ranking and Assignment Methods
+ pkgver = 1.24.1
+ pkgrel = 1
+ url = https://bioconductor.org/packages/iCOBRA
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-dplyr
+ depends = r-dt
+ depends = r-ggplot2
+ depends = r-limma
+ depends = r-reshape2
+ depends = r-rocr
+ depends = r-scales
+ depends = r-shiny
+ depends = r-shinybs
+ depends = r-shinydashboard
+ depends = r-upsetr
+ depends = r-markdown
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/iCOBRA_1.24.1.tar.gz
+ sha256sums = 491bea9d167ed3f437ca56b0740092a4ebde4fefa355e188ded438fd565179bf
+
+pkgname = r-icobra
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c3b82dbab37
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=iCOBRA
+_pkgver=1.24.1
+pkgname=r-${_pkgname,,}
+pkgver=1.24.1
+pkgrel=1
+pkgdesc='Comparison and Visualization of Ranking and Assignment Methods'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-dplyr
+ r-dt
+ r-ggplot2
+ r-limma
+ r-reshape2
+ r-rocr
+ r-scales
+ r-shiny
+ r-shinybs
+ r-shinydashboard
+ r-upsetr
+ r-markdown
+)
+optdepends=(
+ r-knitr
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('491bea9d167ed3f437ca56b0740092a4ebde4fefa355e188ded438fd565179bf')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: