summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 12:43:12 +0800
committerSukanka2022-06-06 12:43:12 +0800
commit80796223eac93e14e47e046bcc10a1e8c1b9e0c0 (patch)
tree050b564ffa86ebf3a88cf88c62f1f10b74dfcc72
downloadaur-80796223eac93e14e47e046bcc10a1e8c1b9e0c0.tar.gz
add r-idpr
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD41
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c518082da8e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = r-idpr
+ pkgdesc = Profiling and Analyzing Intrinsically Disordered Proteins in R
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/idpr
+ arch = any
+ license = LGPL
+ depends = r
+ depends = r-biostrings
+ depends = r-dplyr
+ depends = r-ggplot2
+ depends = r-jsonlite
+ depends = r-magrittr
+ depends = r-plyr
+ depends = r-rlang
+ optdepends = r-ape
+ optdepends = r-knitr
+ optdepends = r-msa
+ optdepends = r-rmarkdown
+ optdepends = r-seqinr
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/idpr_1.6.0.tar.gz
+ sha256sums = 43bc0d17f09729f054a8475e459d80c13085aad2c82a55b21903784e431d87f6
+
+pkgname = r-idpr
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f8e169e1508
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=idpr
+_pkgver=1.6.0
+pkgname=r-${_pkgname,,}
+pkgver=1.6.0
+pkgrel=1
+pkgdesc='Profiling and Analyzing Intrinsically Disordered Proteins in R'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('LGPL')
+depends=(
+ r
+ r-biostrings
+ r-dplyr
+ r-ggplot2
+ r-jsonlite
+ r-magrittr
+ r-plyr
+ r-rlang
+)
+optdepends=(
+ r-ape
+ r-knitr
+ r-msa
+ r-rmarkdown
+ r-seqinr
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('43bc0d17f09729f054a8475e459d80c13085aad2c82a55b21903784e431d87f6')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: