summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-12-09 12:38:47 +0200
committerPekka Ristola2023-12-09 12:38:47 +0200
commitfdebea6e6631027e58fb5386aa4346018e1691a6 (patch)
treed9126e07586416033c4f728b894aac1a10e566d9
downloadaur-fdebea6e6631027e58fb5386aa4346018e1691a6.tar.gz
Version 0.5.24.3
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD51
-rw-r--r--system-robin-map.patch10
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72bc9444b68e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = r-isotree
+ pkgdesc = Isolation-Based Outlier Detection
+ pkgver = 0.5.24.3
+ pkgrel = 1
+ url = https://cran.r-project.org/package=isotree
+ arch = x86_64
+ license = BSD
+ makedepends = robin-map
+ depends = r-rcpp
+ optdepends = r-jsonlite
+ optdepends = r-kableextra
+ optdepends = r-kernlab
+ optdepends = r-knitr
+ optdepends = r-mlbench
+ optdepends = r-mlmetrics
+ optdepends = r-outliertree
+ optdepends = r-rmarkdown
+ source = https://cran.r-project.org/src/contrib/isotree_0.5.24-3.tar.gz
+ source = system-robin-map.patch
+ md5sums = 187c07e96a3e58931b39747e3aa18112
+ md5sums = eb4f3a13cc4014676e7b49b44982d662
+ sha256sums = d46dac42a4fca9d87c5dd46ffa84f4297c11f1831dc2ff6562bfb0897c9a9609
+ sha256sums = 21873d5c2e0fb0ea13156b91de036c7c02b1284a0e262f95b81988161c1915a5
+
+pkgname = r-isotree
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e3acfe28b598
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=isotree
+_pkgver=0.5.24-3
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="Isolation-Based Outlier Detection"
+arch=(x86_64)
+url="https://cran.r-project.org/package=${_pkgname}"
+license=(BSD)
+depends=(
+ r-rcpp
+)
+makedepends=(
+ robin-map
+)
+optdepends=(
+ r-jsonlite
+ r-kableextra
+ r-kernlab
+ r-knitr
+ r-mlbench
+ r-mlmetrics
+ r-outliertree
+ r-rmarkdown
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz"
+ "system-robin-map.patch")
+md5sums=('187c07e96a3e58931b39747e3aa18112'
+ 'eb4f3a13cc4014676e7b49b44982d662')
+sha256sums=('d46dac42a4fca9d87c5dd46ffa84f4297c11f1831dc2ff6562bfb0897c9a9609'
+ '21873d5c2e0fb0ea13156b91de036c7c02b1284a0e262f95b81988161c1915a5')
+
+prepare() {
+ # use system robin-map
+ patch -Np1 -i system-robin-map.patch
+}
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ ln -s "/usr/lib/R/library/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
+}
diff --git a/system-robin-map.patch b/system-robin-map.patch
new file mode 100644
index 000000000000..984adc45b497
--- /dev/null
+++ b/system-robin-map.patch
@@ -0,0 +1,10 @@
+diff --git a/isotree/src/Makevars.in b/isotree/src/Makevars.in
+index 26adc59..f639299 100644
+--- a/isotree/src/Makevars.in
++++ b/isotree/src/Makevars.in
+@@ -1,4 +1,4 @@
+-PKG_CPPFLAGS = -DRCPP_USE_UNWIND_PROTECT -D_FOR_R -D_USE_XOSHIRO -D_USE_ROBIN_MAP @SUPPORTS_RESTRICT@ @LD_SUPPORT@
++PKG_CPPFLAGS = -DRCPP_USE_UNWIND_PROTECT -D_FOR_R -D_USE_XOSHIRO -D_USE_ROBIN_MAP -D_USE_SYSTEM_ROBIN @SUPPORTS_RESTRICT@ @LD_SUPPORT@
+ PKG_CXXFLAGS = $(SHLIB_OPENMP_CXXFLAGS) @FNE_FLAG@ @FNTP_FLAG@ $(CXX_VISIBILITY)
+ PKG_LIBS = $(SHLIB_OPENMP_CXXFLAGS)
+ CXX_STD = @CXX_SUPPORTED@