summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Branham2018-07-16 09:05:49 -0500
committerAlex Branham2018-07-16 09:05:49 -0500
commitaae407443b35bfe4f2c7681175ad2ee3322068e4 (patch)
tree80e77666b70b0c4c92aa07c28434ae10eb710f1b
parent85b14930522910736b25c85d0562cff3ce77d8f5 (diff)
downloadaur-aae407443b35bfe4f2c7681175ad2ee3322068e4.tar.gz
Upkg 1.0.10
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD22
2 files changed, 13 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de2090467a15..18bf8c152fc1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = r-iterators
pkgdesc = Provides Iterator Construct for R
- pkgver = 1.0.9
+ pkgver = 1.0.10
pkgrel = 1
url = https://cran.r-project.org/package=iterators
arch = any
license = Apache
depends = r
optdepends = r-runit
- source = https://cran.r-project.org/src/contrib/iterators_1.0.9.tar.gz
- md5sums = 93db840dc132b34dae8f7b79821a4b0f
+ optdepends = r-foreach
+ source = https://cran.r-project.org/src/contrib/iterators_1.0.10.tar.gz
+ md5sums = 8935d3e59e998ae3e1f81cea5ad23789
pkgname = r-iterators
diff --git a/PKGBUILD b/PKGBUILD
index c7fbdbbfb7c0..d92a2a7dc31a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,22 @@
# Maintainer: Alex Branham <branham@utexas.edu>
-_cranname=iterators
-_cranver=1.0.9
-_pkgtar=${_cranname}_${_cranver}.tar.gz
+_cranver=1.0.10
pkgname=r-iterators
pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc="Provides Iterator Construct for R"
+pkgdesc='Provides Iterator Construct for R'
arch=('any')
-url="https://cran.r-project.org/package=${_cranname}"
+url='https://cran.r-project.org/package=iterators'
license=('Apache')
depends=('r' )
-
-optdepends=('r-runit')
-
-source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
-md5sums=('93db840dc132b34dae8f7b79821a4b0f')
+optdepends=('r-runit' 'r-foreach')
+source=("https://cran.r-project.org/src/contrib/iterators_"$_cranver".tar.gz")
+md5sums=('8935d3e59e998ae3e1f81cea5ad23789')
build(){
- R CMD INSTALL ${_pkgtar} -l $srcdir
+ R CMD INSTALL iterators_"$_cranver".tar.gz -l "$srcdir"
}
package() {
- install -d "$pkgdir/usr/lib/R/library"
- cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+ install -d "$pkgdir"/usr/lib/R/library
+ cp -a --no-preserve=ownership iterators "$pkgdir"/usr/lib/R/library
}