summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2022-03-10 11:12:36 +0200
committerPekka Ristola2022-03-10 11:12:36 +0200
commita281165c3ae8c1efbe6e4bf7ef01e7f89df31d35 (patch)
treeaad1ff3db1e4ec63e532a8ede9bb22cfc2b98d6f
parentdd352cdd2515ff0853c017e3629e2c488b6837b8 (diff)
downloadaur-a281165c3ae8c1efbe6e4bf7ef01e7f89df31d35.tar.gz
Update to 0.9.29
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
3 files changed, 28 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bbae856ccf60..a2ae10821c68 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = r-kernlab
pkgdesc = Kernel-Based Machine Learning Lab
- pkgver = 0.9.27
+ pkgver = 0.9.29
pkgrel = 1
url = https://cran.r-project.org/package=kernlab
+ arch = i686
arch = x86_64
license = GPL2
depends = r
- source = https://cran.r-project.org/src/contrib/kernlab_0.9-27.tar.gz
- md5sums = 2a45749a0ae27126682bd1baa18b85f1
+ source = https://cran.r-project.org/src/contrib/kernlab_0.9-29.tar.gz
+ sha256sums = c3da693a0041dd34f869e7b63a8d8cf7d4bc588ac601bcdddcf7d44f68b3106f
pkgname = r-kernlab
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 16ed19187ae8..121b54897b90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,26 @@
-# Maintainer: Alex Branham <branham@utexas.edu>
-_cranver=0.9-27
-pkgname=r-kernlab
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Alex Branham <branham@utexas.edu>
+
+_cranname=kernlab
+_cranver=0.9-29
+pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc='Kernel-Based Machine Learning Lab'
-arch=('x86_64')
-url='https://cran.r-project.org/package=kernlab'
-license=('GPL2')
-depends=('r' )
-source=("https://cran.r-project.org/src/contrib/kernlab_"$_cranver".tar.gz")
-md5sums=('2a45749a0ae27126682bd1baa18b85f1')
+pkgdesc="Kernel-Based Machine Learning Lab"
+arch=(i686 x86_64)
+url="https://cran.r-project.org/package=${_cranname}"
+license=(GPL2)
+depends=(r)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+sha256sums=('c3da693a0041dd34f869e7b63a8d8cf7d4bc588ac601bcdddcf7d44f68b3106f')
-build(){
- R CMD INSTALL kernlab_"$_cranver".tar.gz -l "$srcdir"
+build() {
+ mkdir -p build
+ R CMD INSTALL "${_cranname}" -l "${srcdir}/build"
}
+
package() {
- install -dm0755 "$pkgdir"/usr/lib/R/library
- cp -a --no-preserve=ownership kernlab "$pkgdir"/usr/lib/R/library
-}
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/${_cranname}" "${pkgdir}/usr/lib/R/library"
+}