summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Branham2018-05-27 15:50:06 -0500
committerAlex Branham2018-05-27 15:50:06 -0500
commit6205ea5750ef011f074dfd57e1be6d05a2a96a6a (patch)
tree3cf5e1b3fbd3ac92fde1c7d342ddca04b293382d
parente0b30df8a87c93516ec84e92821e3eff48dd0e5b (diff)
downloadaur-6205ea5750ef011f074dfd57e1be6d05a2a96a6a.tar.gz
Upkg: 1.20
-rw-r--r--.SRCINFO49
-rw-r--r--PKGBUILD63
2 files changed, 71 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 112aefab4b0c..b8cc3252d828 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,36 @@
pkgbase = r-knitr
- pkgdesc = a general-purpose package for dynamic report generation in r
- pkgver = 1.13
- pkgrel = 1
- url = http://yihui.name/knitr/
- arch = any
- license = GPL
- makedepends = curl
- makedepends = grep
- makedepends = python-html2text
- depends = r>3.0.2
- depends = r-evaluate>=0.8
- depends = r-digest
- depends = r-formatr
- depends = r-highr
- depends = r-markdown
- depends = r-stringr>=0.6
- depends = r-yaml>=2.1.5
+pkgdesc = A general-purpose tool for dynamic report generation in R
+pkgver = 1.20
+pkgrel = 1
+url = https://cran.r-project.org/web/packages/knitr/index.html
+arch = any
+license = GPL
+depends = r
+depends = r-evaluate>=0.10
+depends = r-highr
+depends = r-markdown
+depends = r-stringr>=0.6
+depends = r-yaml
+optdepends = r-dbi
+optdepends = r-digest
+optdepends = r-htmlwidgets
+optdepends = r-httr
+optdepends = r-jpeg
+optdepends = r-juliacall
+optdepends = r-png
+optdepends = r-reticulate
+optdepends = r-rgl
+optdepends = r-rmarkdown
+optdepends = r-showtext
+optdepends = r-tibble
+optdepends = r-tikzdevice
+optdepends = r-tinytex
+optdepends = r-webshot
+optdepends = r-xfun
+optdepends = r-xml2
+optdepends = r-testit
+source = https://cran.r-project.org/src/contrib/knitr_1.20.tar.gz
+md5sums = fa91b1c0f2778c685ee8758e5b3c02b4
pkgname = r-knitr
diff --git a/PKGBUILD b/PKGBUILD
index 577efdba1434..cc2fa6bb046b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,43 @@
-# Maintainer: generated by script at https://github.com/zasdfgbnm/aurcran
-
-_pkgname=knitr
-_pkgnamelower=knitr
-_repo='http://cran.stat.ucla.edu/'
-_cran="https://cran.r-project.org/web/packages/$_pkgname/index.html"
-pkgname=r-$_pkgnamelower
-pkgver=1.13
+# Maintainer: Alex Branham <branham@utexas.edu>
+# Contributor: generated by script at https://github.com/zasdfgbnm/aurcran
+_cranname=knitr
+_cranver=1.20
+pkgname=r-knitr
+pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc='a general-purpose package for dynamic report generation in r'
-arch=(any)
-url="http://yihui.name/knitr/"
+pkgdesc='A general-purpose tool for dynamic report generation in R'
+arch=("any")
+url="https://cran.r-project.org/web/packages/${_cranname}/index.html"
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('fa91b1c0f2778c685ee8758e5b3c02b4')
license=('GPL')
-depends=('r>3.0.2' 'r-evaluate>=0.8' 'r-digest' 'r-formatr' 'r-highr' 'r-markdown' 'r-stringr>=0.6' 'r-yaml>=2.1.5')
-makedepends=('curl' 'grep' 'python-html2text')
-
-pkgver() {
- curl "$_cran" 2>/dev/null|html2text|grep -oP '(?<=Version:).*'|tr '-' '.'|grep -o '[0-9\.]*'
-}
-
-build() {
- Rscript -e "install.packages(\"$_pkgname\", lib=\"$srcdir\", repos=\"$_repo\")"
-}
+depends=('r'
+ 'r-evaluate>=0.10'
+ 'r-highr'
+ 'r-markdown'
+ 'r-stringr>=0.6'
+ 'r-yaml')
+optdepends=('r-dbi'
+ 'r-digest'
+ 'r-htmlwidgets'
+ 'r-httr'
+ 'r-jpeg'
+ 'r-juliacall'
+ 'r-png'
+ 'r-reticulate'
+ 'r-rgl'
+ 'r-rmarkdown'
+ 'r-showtext'
+ 'r-tibble'
+ 'r-tikzdevice'
+ 'r-tinytex'
+ 'r-webshot'
+ 'r-xfun'
+ 'r-xml2'
+ 'r-testit')
package() {
- install -d "$pkgdir/usr/lib/R/library"
- cp -r "$srcdir/$_pkgname" "$pkgdir/usr/lib/R/library"
-} \ No newline at end of file
+ mkdir -p ${pkgdir}/usr/lib/R/library
+ cd "${srcdir}"
+ R CMD INSTALL ${_cranname} -l ${pkgdir}/usr/lib/R/library
+}