summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Branham2018-05-29 10:08:28 -0500
committerAlex Branham2018-05-29 10:08:28 -0500
commit86e519b9d06b461341bc5e721180dd2b87433d36 (patch)
tree4a5695adb0e0a8de7d348714b13e4b15abe898a2
parent6205ea5750ef011f074dfd57e1be6d05a2a96a6a (diff)
downloadaur-86e519b9d06b461341bc5e721180dd2b87433d36.tar.gz
Improve PKGBUILD
-rw-r--r--.SRCINFO64
-rw-r--r--PKGBUILD47
2 files changed, 47 insertions, 64 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8cc3252d828..0aa7be29b058 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,36 +1,36 @@
pkgbase = r-knitr
-pkgdesc = A general-purpose tool for dynamic report generation in R
-pkgver = 1.20
-pkgrel = 1
-url = https://cran.r-project.org/web/packages/knitr/index.html
-arch = any
-license = GPL
-depends = r
-depends = r-evaluate>=0.10
-depends = r-highr
-depends = r-markdown
-depends = r-stringr>=0.6
-depends = r-yaml
-optdepends = r-dbi
-optdepends = r-digest
-optdepends = r-htmlwidgets
-optdepends = r-httr
-optdepends = r-jpeg
-optdepends = r-juliacall
-optdepends = r-png
-optdepends = r-reticulate
-optdepends = r-rgl
-optdepends = r-rmarkdown
-optdepends = r-showtext
-optdepends = r-tibble
-optdepends = r-tikzdevice
-optdepends = r-tinytex
-optdepends = r-webshot
-optdepends = r-xfun
-optdepends = r-xml2
-optdepends = r-testit
-source = https://cran.r-project.org/src/contrib/knitr_1.20.tar.gz
-md5sums = fa91b1c0f2778c685ee8758e5b3c02b4
+ pkgdesc = A general-purpose tool for dynamic report generation in R
+ pkgver = 1.20
+ pkgrel = 1
+ url = https://cran.r-project.org/web/packages/knitr/index.html
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-evaluate
+ depends = r-highr
+ depends = r-markdown
+ depends = r-stringr
+ depends = r-yaml
+ optdepends = r-testit
+ optdepends = r-digest
+ optdepends = r-cran-rgl
+ optdepends = r-rmarkdown
+ optdepends = r-htmlwidgets
+ optdepends = r-webshot
+ optdepends = r-tikzdevice
+ optdepends = r-tinytex
+ optdepends = r-xfun
+ optdepends = r-reticulate
+ optdepends = r-juliacall
+ optdepends = r-png
+ optdepends = r-jpeg
+ optdepends = r-xml2
+ optdepends = r-httr
+ optdepends = r-dbi
+ optdepends = r-showtext
+ optdepends = r-cran-tibble
+ source = https://cran.r-project.org/src/contrib/knitr_1.20.tar.gz
+ md5sums = fa91b1c0f2778c685ee8758e5b3c02b4
pkgname = r-knitr
diff --git a/PKGBUILD b/PKGBUILD
index cc2fa6bb046b..3511d0bdde77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,26 @@
# Maintainer: Alex Branham <branham@utexas.edu>
-# Contributor: generated by script at https://github.com/zasdfgbnm/aurcran
_cranname=knitr
_cranver=1.20
+_pkgtar=${_cranname}_${_cranver}.tar.gz
pkgname=r-knitr
pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc='A general-purpose tool for dynamic report generation in R'
-arch=("any")
+pkgdesc="A general-purpose tool for dynamic report generation in R"
+arch=('any')
url="https://cran.r-project.org/web/packages/${_cranname}/index.html"
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-md5sums=('fa91b1c0f2778c685ee8758e5b3c02b4')
license=('GPL')
-depends=('r'
- 'r-evaluate>=0.10'
- 'r-highr'
- 'r-markdown'
- 'r-stringr>=0.6'
- 'r-yaml')
-optdepends=('r-dbi'
- 'r-digest'
- 'r-htmlwidgets'
- 'r-httr'
- 'r-jpeg'
- 'r-juliacall'
- 'r-png'
- 'r-reticulate'
- 'r-rgl'
- 'r-rmarkdown'
- 'r-showtext'
- 'r-tibble'
- 'r-tikzdevice'
- 'r-tinytex'
- 'r-webshot'
- 'r-xfun'
- 'r-xml2'
- 'r-testit')
+depends=('r' 'r-evaluate' 'r-highr' 'r-markdown' 'r-stringr' 'r-yaml')
+
+optdepends=('r-testit' 'r-digest' 'r-cran-rgl' 'r-rmarkdown' 'r-htmlwidgets' 'r-webshot' 'r-tikzdevice' 'r-tinytex' 'r-xfun' 'r-reticulate' 'r-juliacall' 'r-png' 'r-jpeg' 'r-xml2' 'r-httr' 'r-dbi' 'r-showtext' 'r-cran-tibble')
+
+source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
+md5sums=('fa91b1c0f2778c685ee8758e5b3c02b4')
+build(){
+ R CMD INSTALL ${_pkgtar} -l $srcdir
+}
package() {
- mkdir -p ${pkgdir}/usr/lib/R/library
- cd "${srcdir}"
- R CMD INSTALL ${_cranname} -l ${pkgdir}/usr/lib/R/library
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
}
+