summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2020-03-09 01:21:34 +0300
committerViktor Drobot2020-03-09 01:21:34 +0300
commit50004638417531a2e022a0eaa468f9cdbadf82a8 (patch)
tree0d377f12669454b4a71c7718cef86678de320cb5
parentbae05866f73d32e9b0728b7f1a46de5f1bcfff3d (diff)
downloadaur-50004638417531a2e022a0eaa468f9cdbadf82a8.tar.gz
Fixed PKGBUILD
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD36
2 files changed, 27 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 775f43351829..56a8b5c05040 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = r-lazyeval
- pkgdesc = An alternative approach to non-standard evaluation using formulas. Provides a full implementation of LISP style 'quasiquotation', making it easier to generate code with other code.
+ pkgdesc = Lazy (Non-Standard) Evaluation
pkgver = 0.2.2
pkgrel = 1
url = https://cran.r-project.org/package=lazyeval
arch = i686
arch = x86_64
- license = GPL-3
+ license = GPL3
+ makedepends = gcc
depends = r>=3.1.0
optdepends = r-knitr
optdepends = r-rmarkdown
optdepends = r-testthat
optdepends = r-covr
- source = http://cran.r-project.org/src/contrib/lazyeval_0.2.2.tar.gz
+ source = https://cran.r-project.org/src/contrib/lazyeval_0.2.2.tar.gz
md5sums = 1de725fe0cd496a2535020867458641a
pkgname = r-lazyeval
diff --git a/PKGBUILD b/PKGBUILD
index 019461816806..f2a8ba606eff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,31 @@
-# Maintainer: Matt Frichtl <frichtlm@gmail.com>
-# Contributer: wagnerflo <florian@wagner-flo.net>
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Contributor: Matt Frichtl <frichtlm@gmail.com>
+# Contributor: wagnerflo <florian@wagner-flo.net>
+
_cranname=lazyeval
_cranver=0.2.2
-pkgname=r-$_cranname
-pkgver=${_cranver}
+pkgname=r-${_cranname,,}
+pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc="An alternative approach to non-standard evaluation using formulas. Provides a full implementation of LISP style 'quasiquotation', making it easier to generate code with other code."
-url="https://cran.r-project.org/package=lazyeval"
-arch=('i686' 'x86_64')
-license=('GPL-3')
+pkgdesc="Lazy (Non-Standard) Evaluation"
+arch=(i686 x86_64)
+url="https://cran.r-project.org/package=${_cranname}"
+license=(GPL3)
depends=('r>=3.1.0')
-optdepends=('r-knitr' 'r-rmarkdown' 'r-testthat' 'r-covr')
-source=("http://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+makedepends=(gcc)
+optdepends=(r-knitr r-rmarkdown r-testthat r-covr)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
md5sums=('1de725fe0cd496a2535020867458641a')
+build() {
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
+}
+
package() {
- mkdir -p ${pkgdir}/usr/lib/R/library
- cd ${srcdir}
- R CMD INSTALL ${_cranname} -l ${pkgdir}/usr/lib/R/library
+ cd "${srcdir}"
+
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
}