summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 13:59:00 +0800
committerSukanka2022-06-06 13:59:00 +0800
commitf22b64dca171362713bdc0b8e3a87c5473798b34 (patch)
tree6356578c34ab1f2cd2964982647cbae0e79b43ca
downloadaur-f22b64dca171362713bdc0b8e3a87c5473798b34.tar.gz
add r-lea
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ee20866fe71
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = r-lea
+ pkgdesc = LEA: an R package for Landscape and Ecological Association Studies
+ pkgver = 3.8.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/LEA
+ arch = x86_64
+ license = GPL
+ depends = r
+ optdepends = r-knitr
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/LEA_3.8.0.tar.gz
+ sha256sums = c0fd5b5a66aff94d65b8961409c226966aa96a02eb7d1e9a9e75382226e5b774
+
+pkgname = r-lea
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dcfad9182b5a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=LEA
+_pkgver=3.8.0
+pkgname=r-${_pkgname,,}
+pkgver=3.8.0
+pkgrel=1
+pkgdesc='LEA: an R package for Landscape and Ecological Association Studies'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+)
+optdepends=(
+ r-knitr
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('c0fd5b5a66aff94d65b8961409c226966aa96a02eb7d1e9a9e75382226e5b774')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: