summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 14:01:03 +0800
committerSukanka2022-06-06 14:01:03 +0800
commit85ad3a25b65ac3ddf18a31bcd02c937bf18fde8d (patch)
treee767704f1dba579317d290daee2fb577a6ea194b
downloadaur-85ad3a25b65ac3ddf18a31bcd02c937bf18fde8d.tar.gz
add r-leidenbase
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..080c2b9d1686
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = r-leidenbase
+ pkgdesc = R and C/C++ Wrappers to Run the Leiden find_partition() Function
+ pkgver = 0.1.11
+ pkgrel = 1
+ url = https://cran.r-project.org/package=leidenbase
+ arch = x86_64
+ license = GPL
+ makedepends = gcc-fortran
+ depends = r
+ depends = r-igraph
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://cran.r-project.org/src/contrib/leidenbase_0.1.11.tar.gz
+ sha256sums = 3627c35bc192f43d2ba09aebbb54f2871efefed5978e19492fb75b6df25d12aa
+
+pkgname = r-leidenbase
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..248b5471b405
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=leidenbase
+_pkgver=0.1.11
+pkgname=r-${_pkgname,,}
+pkgver=0.1.11
+pkgrel=1
+pkgdesc='R and C/C++ Wrappers to Run the Leiden find_partition() Function'
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-igraph
+)
+optdepends=(
+ r-knitr
+ r-rmarkdown
+ r-testthat
+)
+makedepends=(
+ gcc-fortran
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('3627c35bc192f43d2ba09aebbb54f2871efefed5978e19492fb75b6df25d12aa')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: