summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-04-07 18:03:07 +0000
committerBioArchLinuxBot2024-04-07 18:03:07 +0000
commit76d6b1177bc5d75b93976f6c1a8a8c38f86f16ce (patch)
tree0825569311038a0dcfdd7d874f8be7c44ebaf9a2
parent302da758661292a64aa08d51ad0df34951e5acad (diff)
downloadaur-76d6b1177bc5d75b93976f6c1a8a8c38f86f16ce.tar.gz
[lilac] updated to 1.0.10-2
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD25
2 files changed, 18 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fcafa179654f..cfd0caf29610 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = r-libcoin
pkgdesc = Linear Test Statistics for Permutation Inference
pkgver = 1.0.10
- pkgrel = 1
+ pkgrel = 2
url = https://cran.r-project.org/package=libcoin
arch = x86_64
- license = GPL
- depends = r
+ license = GPL-2.0-only
+ depends = lapack
depends = r-mvtnorm
optdepends = r-coin
source = https://cran.r-project.org/src/contrib/libcoin_1.0-10.tar.gz
- sha256sums = 3023e0495d0789765bdf04c0ef0990a57b48fefa322c55f20e250d2d70d67eaf
+ md5sums = 36dbba586a222ba373b5b8bbc61729c4
+ b2sums = 43ecb2e4b7a337e81dde4037d4c7d3140bc07c5c9e2cf7da00091cb5c7e3c1133aacba795aa55719f48d193136a4bffec29eea482d60a76ca0ec87fb7cdedb94
pkgname = r-libcoin
diff --git a/PKGBUILD b/PKGBUILD
index 394e536c50a7..e39c0bb3dd7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,28 +4,29 @@
_pkgname=libcoin
_pkgver=1.0-10
pkgname=r-${_pkgname,,}
-pkgver=1.0.10
-pkgrel=1
-pkgdesc='Linear Test Statistics for Permutation Inference'
-arch=('x86_64')
-url="https://cran.r-project.org/package=${_pkgname}"
-license=('GPL')
+pkgver=${_pkgver//-/.}
+pkgrel=2
+pkgdesc="Linear Test Statistics for Permutation Inference"
+arch=(x86_64)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('GPL-2.0-only')
depends=(
- r
+ lapack
r-mvtnorm
)
optdepends=(
r-coin
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('3023e0495d0789765bdf04c0ef0990a57b48fefa322c55f20e250d2d70d67eaf')
+md5sums=('36dbba586a222ba373b5b8bbc61729c4')
+b2sums=('43ecb2e4b7a337e81dde4037d4c7d3140bc07c5c9e2cf7da00091cb5c7e3c1133aacba795aa55719f48d193136a4bffec29eea482d60a76ca0ec87fb7cdedb94')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: