summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-10-26 06:10:38 +0000
committerBioArchLinuxBot2023-10-26 06:10:38 +0000
commit0433807295e8ced70fca3bb0f20b3a705b58dc70 (patch)
tree03227922ce54ca4c9a775d184501cd67797ff4c7
parentea3ef42b8193c0fdf7182b3685878ea938da4ca0 (diff)
downloadaur-0433807295e8ced70fca3bb0f20b3a705b58dc70.tar.gz
[lilac] updated to 3.58.0-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 23 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1bfa4319e006..8d89233fd3db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,26 @@
pkgbase = r-limma
pkgdesc = Linear Models for Microarray Data
- pkgver = 3.56.2
+ pkgver = 3.58.0
pkgrel = 1
url = https://bioconductor.org/packages/limma
arch = x86_64
license = GPL
- depends = r
+ depends = r-statmod
optdepends = r-affy
optdepends = r-annotationdbi
optdepends = r-biasedurn
optdepends = r-biobase
+ optdepends = r-biocstyle
optdepends = r-ellipse
optdepends = r-go.db
optdepends = r-gplots
optdepends = r-illuminaio
+ optdepends = r-knitr
optdepends = r-locfit
- optdepends = r-mass
optdepends = r-org.hs.eg.db
- optdepends = r-splines
- optdepends = r-statmod
optdepends = r-vsn
- source = https://bioconductor.org/packages/release/bioc/src/contrib/limma_3.56.2.tar.gz
- sha256sums = 19d8090708a38d7320e797df27455e60eaafdc02f97ecae62537d8ec925a3e56
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/limma_3.58.0.tar.gz
+ md5sums = 521e5f19c19affa0ead9e097967701e8
+ sha256sums = ee4510e8208e564dc5d32c2ba58741b6a3c155e9b90c5fe4a299e98886f71fd6
pkgname = r-limma
diff --git a/PKGBUILD b/PKGBUILD
index 3f593de862ec..95958352808e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,43 @@
-# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=limma
-_pkgver=3.56.2
+_pkgver=3.58.0
pkgname=r-${_pkgname,,}
-pkgver=3.56.2
+pkgver=${_pkgver//-/.}
pkgrel=1
-pkgdesc='Linear Models for Microarray Data'
-arch=('x86_64')
+pkgdesc="Linear Models for Microarray Data"
+arch=(x86_64)
url="https://bioconductor.org/packages/${_pkgname}"
-license=('GPL')
+license=(GPL)
depends=(
- r
+ r-statmod
)
optdepends=(
r-affy
r-annotationdbi
r-biasedurn
r-biobase
+ r-biocstyle
r-ellipse
r-go.db
r-gplots
r-illuminaio
+ r-knitr
r-locfit
- r-mass
r-org.hs.eg.db
- r-splines
- r-statmod
r-vsn
)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('19d8090708a38d7320e797df27455e60eaafdc02f97ecae62537d8ec925a3e56')
+md5sums=('521e5f19c19affa0ead9e097967701e8')
+sha256sums=('ee4510e8208e564dc5d32c2ba58741b6a3c155e9b90c5fe4a299e98886f71fd6')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: