summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2017-11-14 04:07:58 -0500
committerJean Lucas2017-11-14 04:07:58 -0500
commit163565e1ab4153d2002aac60516248ebef763afd (patch)
tree6bce43df0b50ff27d76c42f0f1c0aa6741f3c519
downloadaur-163565e1ab4153d2002aac60516248ebef763afd.tar.gz
Initial commit, added launch script that works around corrupted graphics
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD31
-rw-r--r--rlinux.sh1
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..829f1c25b559
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Tue Nov 14 09:00:29 UTC 2017
+pkgbase = r-linux
+ pkgdesc = Undelete and data recovery software
+ pkgver = 5.4.165361
+ pkgrel = 1
+ url = http://www.r-tt.com/data_recovery_linux/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = sudo
+ depends = xdg-utils
+ source = rlinux.sh
+ sha512sums = f6630adfd9d2ec1be384f84b53b7d3fff1b93a1ae6f1d34bc06a15eb5e8fd07be28c2c1fcbd6de8d331ac6bda8659eee25e0a03163181f8757f3f15368e72f74
+ source_i686 = https://www.r-tt.com/downloads/RLinux5_i386.deb
+ sha512sums_i686 = 4ca1ce945a2ec66b536b5d136b07166dfb374b0596e6c674d4eca7d6960e81baa6d21ca78088a14e844ec55a1abc7cea16a405b7880f2d8532dbba814318be92
+ source_x86_64 = http://www.r-tt.com/downloads/RLinux5_x64.deb
+ sha512sums_x86_64 = b8753711c6f7f1e5f6ef24aa46ac72bac454655a1241cc98ec6ff4608d7bee99fdba963d00ba59dc4c11ee126becd586c2e64507a5e16d04b56da7a2a6b19424
+
+pkgname = r-linux
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..062a8a990480
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Jean Lucas <jean@4ray.co>
+
+pkgname=r-linux
+pkgver=5.4.165361
+pkgrel=1
+pkgdesc="Undelete and data recovery software"
+arch=('i686' 'x86_64')
+url="http://www.r-tt.com/data_recovery_linux/"
+license=('custom')
+depends=('sudo' 'xdg-utils')
+source_i686=("https://www.r-tt.com/downloads/RLinux5_i386.deb")
+source_x86_64=("http://www.r-tt.com/downloads/RLinux5_x64.deb")
+source=(rlinux.sh)
+sha512sums=('03096de0361b38195d346d2e5eab31b938daf1a824c3939e10232b769b60ba6f2eaf6cc55d553e76953bb6cadd3a35441fac0d0c6551e114cee970c9746cfccc'
+ '16a3c7e30096066b3ab1640f32c421424bfdefdb2859526d0f03dd5e173bc61450ca8371225fe7491135967ffe7c08b9c92b6d5b39bdf7a8999c85b6d7789c4a')
+sha512sums_i686=('4ca1ce945a2ec66b536b5d136b07166dfb374b0596e6c674d4eca7d6960e81baa6d21ca78088a14e844ec55a1abc7cea16a405b7880f2d8532dbba814318be92')
+sha512sums_x86_64=('b8753711c6f7f1e5f6ef24aa46ac72bac454655a1241cc98ec6ff4608d7bee99fdba963d00ba59dc4c11ee126becd586c2e64507a5e16d04b56da7a2a6b19424')
+sha512sums=('f6630adfd9d2ec1be384f84b53b7d3fff1b93a1ae6f1d34bc06a15eb5e8fd07be28c2c1fcbd6de8d331ac6bda8659eee25e0a03163181f8757f3f15368e72f74')
+
+package() {
+ cd $srcdir
+
+ tar xvf data.tar.gz
+ cp -r usr $pkgdir
+
+ rm $pkgdir/usr/bin/rlinux
+
+ install -Dm 755 $srcdir/rlinux.sh $pkgdir/usr/bin/rlinux
+ install -Dm 644 $pkgdir/usr/local/R-Linux/share/logo_48.png $pkgdir/usr/share/pixmaps/rtt-rlinux.desktop
+ install -Dm 644 $pkgdir/usr/local/R-Linux/share/rtt-rlinux.desktop $pkgdir/usr/share/applications/rtt-rlinux.desktop
+}
diff --git a/rlinux.sh b/rlinux.sh
new file mode 100644
index 000000000000..5c5392bfe177
--- /dev/null
+++ b/rlinux.sh
@@ -0,0 +1 @@
+sudo QT_X11_NO_MITSHM=1 /usr/local/R-Linux/bin/rlinux