summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 14:41:30 +0800
committerSukanka2022-06-06 14:41:30 +0800
commit1df9d673fce5ddaefb0d23ab30d1de21bc4be3d1 (patch)
tree4846b17e8ffe634e2ba6a5800ac3f54eea3037a9
downloadaur-1df9d673fce5ddaefb0d23ab30d1de21bc4be3d1.tar.gz
add r-maskbad
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ecb9ea082d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = r-maskbad
+ pkgdesc = Masking probes with binding affinity differences
+ pkgver = 1.40.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/maskBAD
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-affy
+ depends = r-gcrma
+ optdepends = r-hgu95av2cdf
+ optdepends = r-hgu95av2probe
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/maskBAD_1.40.0.tar.gz
+ sha256sums = b2acc07780b0dfb2326dcfdf898728c77ef0b99c663da14b5b64575920b75f15
+
+pkgname = r-maskbad
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..307f2fa01ea1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=maskBAD
+_pkgver=1.40.0
+pkgname=r-${_pkgname,,}
+pkgver=1.40.0
+pkgrel=1
+pkgdesc='Masking probes with binding affinity differences'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-affy
+ r-gcrma
+)
+optdepends=(
+ r-hgu95av2cdf
+ r-hgu95av2probe
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('b2acc07780b0dfb2326dcfdf898728c77ef0b99c663da14b5b64575920b75f15')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: