summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2020-01-31 17:53:53 +0300
committerViktor Drobot2020-01-31 17:53:53 +0300
commitefc2fcb048747f0324398581178f55f7c5c92477 (patch)
treed486d5983f46ab9857ee5c7ece0d74d04c8481ad
parent418c7cb108eb39d78516d356dad2924a572256f7 (diff)
downloadaur-efc2fcb048747f0324398581178f55f7c5c92477.tar.gz
Fixed PKGBUILD
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 34 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 35774d2dd696..5954f6499c75 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,11 +2,19 @@ pkgbase = r-matrixstats
pkgdesc = Functions that Apply to Rows and Columns of Matrices (and to Vectors)
pkgver = 0.55.0
pkgrel = 1
- url = https://CRAN.R-project.org/package=matrixStats
+ url = https://cran.r-project.org/package=matrixStats
+ arch = i686
arch = x86_64
- license = GPL3
- depends = r
- source = http://cran.r-project.org/src/contrib/matrixStats_0.55.0.tar.gz
+ license = Artistic-2.0
+ makedepends = gcc
+ depends = r>=2.12.0
+ optdepends = r-base64enc
+ optdepends = r-ggplot2
+ optdepends = r-knitr
+ optdepends = r-microbenchmark
+ optdepends = r-r.devices
+ optdepends = r-r.rsp
+ source = https://cran.r-project.org/src/contrib/matrixStats_0.55.0.tar.gz
md5sums = 860aa7af56ddb598268cbca7921e2d4c
pkgname = r-matrixstats
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 6ae0b18a1f6c..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-/pkg
-/src
-*.tar.gz
-*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index c0b748319a0c..610a4650983e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,30 @@
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Grey Christoforo <first name at last name dot net>
-pkgname=r-matrixstats
-_cran_name=matrixStats
-pkgver=0.55.0
+
+_cranname=matrixStats
+_cranver=0.55.0
+pkgname=r-${_cranname,,}
+pkgver=${_cranver//[:-]/.}
pkgrel=1
pkgdesc="Functions that Apply to Rows and Columns of Matrices (and to Vectors)"
-arch=('x86_64')
-url="https://CRAN.R-project.org/package=${_cran_name}"
-license=('GPL3')
-depends=('r')
-source=("http://cran.r-project.org/src/contrib/${_cran_name}_${pkgver}.tar.gz")
+arch=(i686 x86_64)
+url="https://cran.r-project.org/package=${_cranname}"
+license=(Artistic-2.0)
+depends=('r>=2.12.0')
+makedepends=(gcc)
+optdepends=(r-base64enc r-ggplot2 r-knitr r-microbenchmark r-r.devices r-r.rsp)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
md5sums=('860aa7af56ddb598268cbca7921e2d4c')
+build() {
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
+}
+
package() {
- mkdir -p $pkgdir/usr/lib/R/library
- cd $srcdir
+ cd "${srcdir}"
- R CMD INSTALL -l $pkgdir/usr/lib/R/library ./${_cran_name}
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
}