summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 15:20:44 +0800
committerSukanka2022-06-06 15:20:44 +0800
commit0fa080e2f68da593601a92f3e40726b9f741d36c (patch)
tree1718f4f5bb2e4659d64002faa16e71f948be8777
downloadaur-0fa080e2f68da593601a92f3e40726b9f741d36c.tar.gz
add r-methrix
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD53
2 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0c53b7b2dfe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = r-methrix
+ pkgdesc = Fast and efficient summarization of generic bedGraph files from Bisufite sequencing
+ pkgver = 1.10.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/methrix
+ arch = any
+ license = MIT
+ depends = r
+ depends = r-bsgenome
+ depends = r-data.table
+ depends = r-delayedarray
+ depends = r-delayedmatrixstats
+ depends = r-genomicranges
+ depends = r-ggplot2
+ depends = r-hdf5array
+ depends = r-iranges
+ depends = r-matrixstats
+ depends = r-rtracklayer
+ depends = r-summarizedexperiment
+ optdepends = r-biostrings
+ optdepends = r-bsgenome.mmusculus.ucsc.mm9
+ optdepends = r-bsseq
+ optdepends = r-dss
+ optdepends = r-genomeinfodb
+ optdepends = r-genomicscores
+ optdepends = r-knitr
+ optdepends = r-mafdb.1kgenomes.phase3.grch38
+ optdepends = r-mafdb.1kgenomes.phase3.hs37d5
+ optdepends = r-plotly
+ optdepends = r-rcolorbrewer
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/methrix_1.10.0.tar.gz
+ sha256sums = 92d93bb3e273307cca204c00b8d18e7efa48d6cfe72206d69053f9b3bfba271c
+
+pkgname = r-methrix
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2198f9ff9566
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=methrix
+_pkgver=1.10.0
+pkgname=r-${_pkgname,,}
+pkgver=1.10.0
+pkgrel=1
+pkgdesc='Fast and efficient summarization of generic bedGraph files from Bisufite sequencing'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('MIT')
+depends=(
+ r
+ r-bsgenome
+ r-data.table
+ r-delayedarray
+ r-delayedmatrixstats
+ r-genomicranges
+ r-ggplot2
+ r-hdf5array
+ r-iranges
+ r-matrixstats
+ r-rtracklayer
+ r-summarizedexperiment
+)
+optdepends=(
+ r-biostrings
+ r-bsgenome.mmusculus.ucsc.mm9
+ r-bsseq
+ r-dss
+ r-genomeinfodb
+ r-genomicscores
+ r-knitr
+ r-mafdb.1kgenomes.phase3.grch38
+ r-mafdb.1kgenomes.phase3.hs37d5
+ r-plotly
+ r-rcolorbrewer
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('92d93bb3e273307cca204c00b8d18e7efa48d6cfe72206d69053f9b3bfba271c')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: