summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-06-18 00:04:48 +0000
committerBioArchLinuxBot2023-06-18 00:04:48 +0000
commitce331552f89ffd6c4e6e4af3938cde09e87e1dea (patch)
tree6a7a23737ec8c2c92b98ec6508cc7c130bc3c3a6
parentd7b139be0382f48465cc1d1d5277fe22fa814370 (diff)
downloadaur-ce331552f89ffd6c4e6e4af3938cde09e87e1dea.tar.gz
[lilac] updated to 1.8.3-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD27
2 files changed, 22 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8068a897b5b6..4c68afda2ea4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = r-methylscaper
pkgdesc = Visualization of Methylation Data
- pkgver = 1.8.0
+ pkgver = 1.8.3
pkgrel = 1
url = https://bioconductor.org/packages/methylscaper
arch = any
- license = GPL
- depends = r
+ license = GPL2
depends = r-biocparallel
depends = r-biostrings
depends = r-data.table
@@ -16,10 +15,13 @@ pkgbase = r-methylscaper
depends = r-shinyfiles
depends = r-shinyjs
depends = r-summarizedexperiment
+ optdepends = r-biocstyle
optdepends = r-devtools
optdepends = r-knitr
+ optdepends = r-r.utils
optdepends = r-rmarkdown
- source = https://bioconductor.org/packages/release/bioc/src/contrib/methylscaper_1.8.0.tar.gz
- sha256sums = 154eeadceaf54a4437e238a050bfa8ebf184241636936f430d7b791a1586f4c3
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/methylscaper_1.8.3.tar.gz
+ md5sums = d60bd7f7fae645fd76f981abfde99c50
+ sha256sums = d32dfafcc4ff4f12de9665ab9d16d28d45e7cb8f105403dd8ccb5315e5ece74d
pkgname = r-methylscaper
diff --git a/PKGBUILD b/PKGBUILD
index e262dd6179bf..92f85bceae26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
-# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=methylscaper
-_pkgver=1.8.0
+_pkgver=1.8.3
pkgname=r-${_pkgname,,}
-pkgver=1.8.0
+pkgver=${_pkgver//[:-]/.}
pkgrel=1
-pkgdesc='Visualization of Methylation Data'
-arch=('any')
+pkgdesc="Visualization of Methylation Data"
+arch=(any)
url="https://bioconductor.org/packages/${_pkgname}"
-license=('GPL')
+license=(GPL2)
depends=(
- r
r-biocparallel
r-biostrings
r-data.table
@@ -23,19 +23,22 @@ depends=(
r-summarizedexperiment
)
optdepends=(
+ r-biocstyle
r-devtools
r-knitr
+ r-r.utils
r-rmarkdown
)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('154eeadceaf54a4437e238a050bfa8ebf184241636936f430d7b791a1586f4c3')
+md5sums=('d60bd7f7fae645fd76f981abfde99c50')
+sha256sums=('d32dfafcc4ff4f12de9665ab9d16d28d45e7cb8f105403dd8ccb5315e5ece74d')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: