summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-12-29 12:06:25 +0000
committerBioArchLinuxBot2023-12-29 12:06:25 +0000
commit126463e508670181f2106bd14ace43c3e9830b55 (patch)
tree6299efcb461cfcfe05af2e627c451fcc631c2c59
parented1e0a96b38ecbf8a17bed3658899a2e6cbc678c (diff)
downloadaur-126463e508670181f2106bd14ace43c3e9830b55.tar.gz
[lilac] updated to 1.4.10-2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD29
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 35f27fadda2a..61602757bc3e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = r-microbenchmark
pkgdesc = Accurate Timing Functions
pkgver = 1.4.10
- pkgrel = 1
+ pkgrel = 2
url = https://cran.r-project.org/package=microbenchmark
arch = x86_64
license = BSD
depends = r
- depends = gcc
optdepends = r-ggplot2
optdepends = r-multcomp
optdepends = r-runit
source = https://cran.r-project.org/src/contrib/microbenchmark_1.4.10.tar.gz
- sha256sums = 04cc41be72708dce8d31ff1cb105d88cc9f167250ea00fe9a165c99204b9b481
+ md5sums = c64e467a01e792461a5cc544eac12f15
+ b2sums = 458cb280410737719481b65b6bdd7281bf2c4d8320af55477f747c3b90c5f2d39c138b407ab2e64ea6a4dcafa3bdb6daa531a6a5fa94904dfe31672273f31a88
pkgname = r-microbenchmark
diff --git a/PKGBUILD b/PKGBUILD
index 5250bba453e9..2a684c6ddc73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,16 @@
-# system requirements: On a Unix-alike, one of the C functionsmach_absolute_time (macOS), clock_gettime or gethrtime. If noneof these is found, the obsolescent POSIX function gettimeofdaywill be tried.
# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=microbenchmark
_pkgver=1.4.10
pkgname=r-${_pkgname,,}
-pkgver=1.4.10
-pkgrel=1
-pkgdesc='Accurate Timing Functions'
-arch=('x86_64')
-url="https://cran.r-project.org/package=${_pkgname}"
-license=('BSD')
+pkgver=${_pkgver//-/.}
+pkgrel=2
+pkgdesc="Accurate Timing Functions"
+arch=(x86_64)
+url="https://cran.r-project.org/package=$_pkgname"
+license=(BSD)
depends=(
r
- gcc
)
optdepends=(
r-ggplot2
@@ -20,15 +18,18 @@ optdepends=(
r-runit
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('04cc41be72708dce8d31ff1cb105d88cc9f167250ea00fe9a165c99204b9b481')
+md5sums=('c64e467a01e792461a5cc544eac12f15')
+b2sums=('458cb280410737719481b65b6bdd7281bf2c4d8320af55477f747c3b90c5f2d39c138b407ab2e64ea6a4dcafa3bdb6daa531a6a5fa94904dfe31672273f31a88')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
- install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ ln -s "/usr/lib/R/library/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
}
-# vim:set ts=2 sw=2 et: