summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-11-26 16:01:43 +0200
committerPekka Ristola2023-11-26 16:01:43 +0200
commit9842739a462e97481c4b510e8c58bbdf8ac662b0 (patch)
treedcf3331b40a429a776637da1cd9197435fe2e45f
downloadaur-9842739a462e97481c4b510e8c58bbdf8ac662b0.tar.gz
Version 1.0.0
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD53
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d498207e3411
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = r-micsqtl
+ pkgdesc = MICSQTL (Multi-omic deconvolution, Integration and Cell-type-specific Quantitative Trait Loci)
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/MICSQTL
+ arch = any
+ license = GPL3
+ checkdepends = r-testthat
+ depends = r-biocparallel
+ depends = r-dirmult
+ depends = r-ggplot2
+ depends = r-ggpubr
+ depends = r-ggridges
+ depends = r-glue
+ depends = r-magrittr
+ depends = r-nnls
+ depends = r-purrr
+ depends = r-s4vectors
+ depends = r-summarizedexperiment
+ depends = r-tca
+ depends = r-toast
+ optdepends = r-biocstyle
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/MICSQTL_1.0.0.tar.gz
+ md5sums = ec49e08df014da6955d2b6ab7dc77d3b
+ sha256sums = eff898a4768e67af1bc6b1cb6664cf24675f7ba1acbbb8fddc920507370ce1e0
+
+pkgname = r-micsqtl
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c70ba43155e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=MICSQTL
+_pkgver=1.0.0
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="MICSQTL (Multi-omic deconvolution, Integration and Cell-type-specific Quantitative Trait Loci)"
+arch=(any)
+url="https://bioconductor.org/packages/${_pkgname}"
+license=(GPL3)
+depends=(
+ r-biocparallel
+ r-dirmult
+ r-ggplot2
+ r-ggpubr
+ r-ggridges
+ r-glue
+ r-magrittr
+ r-nnls
+ r-purrr
+ r-s4vectors
+ r-summarizedexperiment
+ r-tca
+ r-toast
+)
+checkdepends=(
+ r-testthat
+)
+optdepends=(
+ r-biocstyle
+ r-knitr
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('ec49e08df014da6955d2b6ab7dc77d3b')
+sha256sums=('eff898a4768e67af1bc6b1cb6664cf24675f7ba1acbbb8fddc920507370ce1e0')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+}