summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-07 00:27:26 +0800
committerSukanka2022-06-07 00:27:26 +0800
commitaaa784a01084d4689c5f1cd5ce60ed4d7a0f1e5e (patch)
tree79e8f939336418ef996e3d1053d68ebb768ff647
downloadaur-aaa784a01084d4689c5f1cd5ce60ed4d7a0f1e5e.tar.gz
add r-mirtarrnaseq
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD43
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..76ff1fa26ae9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = r-mirtarrnaseq
+ pkgdesc = mirTarRnaSeq
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/mirTarRnaSeq
+ arch = any
+ license = MIT
+ depends = r
+ depends = r-assertthat
+ depends = r-catools
+ depends = r-corrplot
+ depends = r-data.table
+ depends = r-dplyr
+ depends = r-pheatmap
+ depends = r-pscl
+ depends = r-purrr
+ depends = r-r.utils
+ depends = r-reshape2
+ depends = r-ggplot2
+ optdepends = r-biocstyle
+ optdepends = r-knitr
+ optdepends = r-r.cache
+ optdepends = r-rmarkdown
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/mirTarRnaSeq_1.4.0.tar.gz
+ sha256sums = c1df6520d00af1bd102e14708504be425d61f6bfe08ac9d157ca7beadaf08083
+
+pkgname = r-mirtarrnaseq
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc8ee68b8a81
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=mirTarRnaSeq
+_pkgver=1.4.0
+pkgname=r-${_pkgname,,}
+pkgver=1.4.0
+pkgrel=1
+pkgdesc='mirTarRnaSeq'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('MIT')
+depends=(
+ r
+ r-assertthat
+ r-catools
+ r-corrplot
+ r-data.table
+ r-dplyr
+ r-pheatmap
+ r-pscl
+ r-purrr
+ r-r.utils
+ r-reshape2
+ r-ggplot2
+)
+optdepends=(
+ r-biocstyle
+ r-knitr
+ r-r.cache
+ r-rmarkdown
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('c1df6520d00af1bd102e14708504be425d61f6bfe08ac9d157ca7beadaf08083')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: