summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Phinikarides2016-12-03 00:35:19 +0200
committerAlexander Phinikarides2016-12-03 00:35:19 +0200
commit530cd8848e8b85b7cf8cefa6a6f19e2c46715128 (patch)
tree331a5fc7171c1487399442d62d094120275497e5
parent847eee8a2e53aba826e6f761cf380abb3dc8b7bb (diff)
downloadaur-530cd8848e8b85b7cf8cefa6a6f19e2c46715128.tar.gz
fixed fortran libs
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 6 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 277b523aa336..0cbbe813badc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = r-mkl
pkgdesc = Language and environment for statistical computing and graphics, linked with Intel's MKL.
pkgver = 3.3.2
- pkgrel = 4
+ pkgrel = 5
url = http://www.r-project.org/
install = r-mkl.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index f9dec3177bcc..3dc29228d124 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=r-mkl
pkgver=3.3.2
-pkgrel=4
+pkgrel=5
pkgdesc="Language and environment for statistical computing and graphics, linked with Intel's MKL."
arch=('x86_64')
license=('GPL')
@@ -86,7 +86,7 @@ build() {
source /opt/intel/mkl/bin/mklvars.sh ${_intel_arch}
if [ $_CC = "icc" ]; then
- source /opt/intel/composerxe/linux/bin/compilervars.sh ${_intel_arch}
+ source ${MKLROOT}/../bin/compilervars.sh ${_intel_arch}
_intel_cc_opt=" -O3 -qno-opt-matmul -xHost -m64 -qopenmp -ipo -fp-model precise -fp-model source -qopt-mem-layout-trans=2 -diag-disable=188,308"
export MAIN_LDFLAGS=" -qopenmp"
export FLIBS=" -lgfortran -lifcore -lifport"
@@ -96,14 +96,12 @@ build() {
-lmkl_intel_thread \
-lmkl_core \
-liomp5 \
- -lsvml \
- -lirc \
- -lunwind \
- -lifcore \
- -lifport \
-lpthread \
-lm \
-ldl \
+ -lsvml \
+ -lirc \
+ -lunwind \
-lifcore \
-lifport"
# Including -lifcore and -lifport twice fixes