summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Phinikarides2016-12-29 19:29:03 +0200
committerAlexander Phinikarides2016-12-29 19:29:03 +0200
commitd145c974c704d93642099d4b7b77fbd05d3430be (patch)
tree6d0de645ae15e7b058de4c55080000098c0c8896
parent93e5255566ba13570a89f56faa951a8312a67f25 (diff)
downloadaur-d145c974c704d93642099d4b7b77fbd05d3430be.tar.gz
dynamic library does not work
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f44e4965fc2..cd0811099a7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = r-mkl
pkgdesc = Language and environment for statistical computing and graphics, linked to the Intel(R) MKL.
pkgver = 3.3.2
- pkgrel = 7
+ pkgrel = 8
url = http://www.r-project.org/
install = r-mkl.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 0ff33a7bd510..878720aecd8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=r-mkl
pkgver=3.3.2
-pkgrel=7
+pkgrel=8
pkgdesc="Language and environment for statistical computing and graphics, linked to the Intel(R) MKL."
arch=('x86_64')
license=('GPL')
@@ -93,9 +93,12 @@ build() {
export MAIN_LDFLAGS=${_intel_cc_opt}
export FLIBS=" -lgfortran -lifcore -lifport"
- # Single Dynamic Library (SDL)
+ # Dynamic Linking
_mkllibs=" -L${MKLROOT}/lib/${_intel_arch} \
- -lmkl_rt \
+ -l${_intel_lib} \
+ -lmkl_intel_thread \
+ -lmkl_core \
+ -liomp5 \
-lpthread \
-lm \
-ldl"
@@ -114,8 +117,7 @@ build() {
_gcc_opt=" -O3 -m64 -fopenmp"
export MAIN_LDFLAGS=" -fopenmp"
- # Single Dynamic Library does not work for GCC
- # Using Dynamic Linking
+ # Dynamic Linking
_mkllibs=" -L${MKLROOT}/lib/${_intel_arch} \
-Wl,--no-as-needed \
-l${_gfortran_lib} \