summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-04-07 12:06:28 +0000
committerBioArchLinuxBot2024-04-07 12:06:28 +0000
commitf6c3a3c8dbc421233e599709e52843ba98845fa7 (patch)
tree857ebb14efea22569dfc5b9d32e949fc3d095fcc
parent509b58e38d9697ab48447b231e8a0d6dbd161463 (diff)
downloadaur-f6c3a3c8dbc421233e599709e52843ba98845fa7.tar.gz
[lilac] updated to 1.10.0-2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD27
2 files changed, 18 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 194fcc1093c6..649ad55b2328 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = r-modcon
pkgdesc = Modifying splice site usage by changing the mRNP code, while maintaining the genetic code
pkgver = 1.10.0
- pkgrel = 1
+ pkgrel = 2
url = https://bioconductor.org/packages/ModCon
arch = any
- license = GPL
- depends = r
- depends = r-data.table
+ license = GPL-3.0-only AND LGPL-3.0-only
depends = perl
+ depends = r-data.table
optdepends = r-dplyr
optdepends = r-knitr
optdepends = r-rmarkdown
@@ -18,6 +17,7 @@ pkgbase = r-modcon
optdepends = r-shinyjs
optdepends = r-testthat
source = https://bioconductor.org/packages/release/bioc/src/contrib/ModCon_1.10.0.tar.gz
- sha256sums = 5c22734c752cc7998326b4be8eb5041e782d9c15fdc51c2168f4ce0d6f413f9d
+ md5sums = bdb0634e890917a01325519cf6e53f90
+ b2sums = 69036a052f11ca4369c4b25a60ad246b63cd2600943dbc621c3061c81864717ee0e43e9290dafcb48665f17f8850eab8c203d447d52f344dd493dd8ceeec4109
pkgname = r-modcon
diff --git a/PKGBUILD b/PKGBUILD
index 7f96cad400c6..ce051977b4fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,17 @@
-# system requirements: Perl
# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=ModCon
_pkgver=1.10.0
pkgname=r-${_pkgname,,}
-pkgver=1.10.0
-pkgrel=1
-pkgdesc='Modifying splice site usage by changing the mRNP code, while maintaining the genetic code'
-arch=('any')
-url="https://bioconductor.org/packages/${_pkgname}"
-license=('GPL')
+pkgver=${_pkgver//-/.}
+pkgrel=2
+pkgdesc="Modifying splice site usage by changing the mRNP code, while maintaining the genetic code"
+arch=(any)
+url="https://bioconductor.org/packages/$_pkgname"
+license=('GPL-3.0-only AND LGPL-3.0-only')
depends=(
- r
- r-data.table
perl
+ r-data.table
)
optdepends=(
r-dplyr
@@ -27,14 +25,15 @@ optdepends=(
r-testthat
)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('5c22734c752cc7998326b4be8eb5041e782d9c15fdc51c2168f4ce0d6f413f9d')
+md5sums=('bdb0634e890917a01325519cf6e53f90')
+b2sums=('69036a052f11ca4369c4b25a60ad246b63cd2600943dbc621c3061c81864717ee0e43e9290dafcb48665f17f8850eab8c203d447d52f344dd493dd8ceeec4109')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: