summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 16:08:22 +0800
committerSukanka2022-06-06 16:08:22 +0800
commit82ce078fae1c8a0e6dc7afd1dc1ed50f427f12db (patch)
tree26e04fd4b124d4e74982034dfc5d77b4cc6563dd
downloadaur-82ce078fae1c8a0e6dc7afd1dc1ed50f427f12db.tar.gz
add r-monocle
-rw-r--r--.SRCINFO46
-rw-r--r--PKGBUILD62
2 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5497ca586ae7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,46 @@
+pkgbase = r-monocle
+ pkgdesc = Clustering, differential expression, and trajectory analysis for single- cell RNA-Seq
+ pkgver = 2.24.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/monocle
+ arch = x86_64
+ license = Artistic2.0
+ depends = r
+ depends = r-biobase
+ depends = r-biocgenerics
+ depends = r-biocviews
+ depends = r-combinat
+ depends = r-ddrtree
+ depends = r-densityclust
+ depends = r-dplyr
+ depends = r-fastica
+ depends = r-ggplot2
+ depends = r-hsmmsinglecell
+ depends = r-igraph
+ depends = r-irlba
+ depends = r-limma
+ depends = r-matrixstats
+ depends = r-pheatmap
+ depends = r-plyr
+ depends = r-proxy
+ depends = r-qlcmatrix
+ depends = r-rann
+ depends = r-rcpp
+ depends = r-reshape2
+ depends = r-rtsne
+ depends = r-slam
+ depends = r-stringr
+ depends = r-tibble
+ depends = r-vgam
+ depends = r-viridis
+ depends = r-leidenbase
+ optdepends = r-destiny
+ optdepends = r-hmisc
+ optdepends = r-knitr
+ optdepends = r-scater
+ optdepends = r-seurat
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/monocle_2.24.0.tar.gz
+ sha256sums = ab51c719f2b9d7fcd32805a057e7e27370e0b0e8f6d5b653f751c808f169d8bb
+
+pkgname = r-monocle
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e1fbdd142081
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=monocle
+_pkgver=2.24.0
+pkgname=r-${_pkgname,,}
+pkgver=2.24.0
+pkgrel=1
+pkgdesc='Clustering, differential expression, and trajectory analysis for single- cell RNA-Seq'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-biobase
+ r-biocgenerics
+ r-biocviews
+ r-combinat
+ r-ddrtree
+ r-densityclust
+ r-dplyr
+ r-fastica
+ r-ggplot2
+ r-hsmmsinglecell
+ r-igraph
+ r-irlba
+ r-limma
+ r-matrixstats
+ r-pheatmap
+ r-plyr
+ r-proxy
+ r-qlcmatrix
+ r-rann
+ r-rcpp
+ r-reshape2
+ r-rtsne
+ r-slam
+ r-stringr
+ r-tibble
+ r-vgam
+ r-viridis
+ r-leidenbase
+)
+optdepends=(
+ r-destiny
+ r-hmisc
+ r-knitr
+ r-scater
+ r-seurat
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('ab51c719f2b9d7fcd32805a057e7e27370e0b0e8f6d5b653f751c808f169d8bb')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: