summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-02-29 00:02:33 +0000
committerBioArchLinuxBot2024-02-29 00:02:33 +0000
commit44dfa50a312f0b49aeba9cef8190989bb7d5ba08 (patch)
tree99cb013c1b93018274810aa85f068191af773358
parent67080122c50cfb469c7b7f82339815d7943186fc (diff)
downloadaur-44dfa50a312f0b49aeba9cef8190989bb7d5ba08.tar.gz
[lilac] updated to 0.1.9-3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD24
2 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a719bd4ca50f..78201dae6361 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = r-multcompview
pkgdesc = Visualizations of Paired Comparisons
pkgver = 0.1.9
- pkgrel = 1
+ pkgrel = 3
url = https://cran.r-project.org/package=multcompView
arch = any
- license = GPL
+ license = GPL-2.0-or-later
depends = r
- optdepends = r-mass
optdepends = r-multcomp
optdepends = r-pgirmess
source = https://cran.r-project.org/src/contrib/multcompView_0.1-9.tar.gz
- sha256sums = 1f3993e9d51f3c7a711a881b6a20081a85ffab60c27828ceb3640a6b4c887397
+ md5sums = 78c19f8277cd060fc31628b3ac8188be
+ b2sums = 7e780ba698a987d9be08916f7a806037cf1a61836144d0fcbdc1aae56e3a9df2cab437e23cde3165449d410299e9829891a209c3aa5360c902c85bfabbb10c82
pkgname = r-multcompview
diff --git a/PKGBUILD b/PKGBUILD
index cd023be0696f..55db76b311b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,29 +4,29 @@
_pkgname=multcompView
_pkgver=0.1-9
pkgname=r-${_pkgname,,}
-pkgver=0.1.9
-pkgrel=1
-pkgdesc='Visualizations of Paired Comparisons'
-arch=('any')
-url="https://cran.r-project.org/package=${_pkgname}"
-license=('GPL')
+pkgver=${_pkgver//-/.}
+pkgrel=3
+pkgdesc="Visualizations of Paired Comparisons"
+arch=(any)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('GPL-2.0-or-later')
depends=(
r
)
optdepends=(
- r-mass
r-multcomp
r-pgirmess
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('1f3993e9d51f3c7a711a881b6a20081a85ffab60c27828ceb3640a6b4c887397')
+md5sums=('78c19f8277cd060fc31628b3ac8188be')
+b2sums=('7e780ba698a987d9be08916f7a806037cf1a61836144d0fcbdc1aae56e3a9df2cab437e23cde3165449d410299e9829891a209c3aa5360c902c85bfabbb10c82')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: