summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-03-04 12:06:10 +0000
committerBioArchLinuxBot2024-03-04 12:06:10 +0000
commit2f6984f7049fd1f52002f7839c712db5ffd7ac6d (patch)
tree3fe624654ac5fd0b87cd285851f4fcb18e3bf711
parent0ae6a97d0d53e778952dbc2c8a1b305078fdee4e (diff)
downloadaur-2f6984f7049fd1f52002f7839c712db5ffd7ac6d.tar.gz
[lilac] updated to 1.12.3-2
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 26 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index edb91aa83c8b..4051f01dbff4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = r-multicrispr
pkgdesc = Multi-locus multi-purpose Crispr/Cas design
pkgver = 1.12.3
- pkgrel = 1
+ pkgrel = 2
url = https://bioconductor.org/packages/multicrispr
arch = any
- license = GPL
- depends = r
- depends = r-assertive
+ license = GPL-2.0-only
+ depends = r-assertive.base
+ depends = r-assertive.files
+ depends = r-assertive.numbers
+ depends = r-assertive.reflection
+ depends = r-assertive.sets
depends = r-biocgenerics
depends = r-biostrings
depends = r-bsgenome
@@ -38,6 +41,7 @@ pkgbase = r-multicrispr
optdepends = r-testthat
optdepends = r-txdb.mmusculus.ucsc.mm10.knowngene
source = https://bioconductor.org/packages/release/bioc/src/contrib/multicrispr_1.12.3.tar.gz
- sha256sums = abf0ec2d4d8e9030e86a42449b5729a08e292040e4af711bcc72ca72bbdb508d
+ md5sums = d0bbc847e39772348376d944c884290a
+ b2sums = ed79977a043b0bf57b139d7f304568fd88d7bb7317c673e58f459908fb0330c545243798cdaec86fd56bdf3f0c2e67270e67e0f8f341d280b35b130d4d898be8
pkgname = r-multicrispr
diff --git a/PKGBUILD b/PKGBUILD
index c28fbf599f3c..f023a610aa02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,18 @@
_pkgname=multicrispr
_pkgver=1.12.3
pkgname=r-${_pkgname,,}
-pkgver=1.12.3
-pkgrel=1
-pkgdesc='Multi-locus multi-purpose Crispr/Cas design'
-arch=('any')
-url="https://bioconductor.org/packages/${_pkgname}"
-license=('GPL')
+pkgver=${_pkgver//-/.}
+pkgrel=2
+pkgdesc="Multi-locus multi-purpose Crispr/Cas design"
+arch=(any)
+url="https://bioconductor.org/packages/$_pkgname"
+license=('GPL-2.0-only')
depends=(
- r
- r-assertive
+ r-assertive.base
+ r-assertive.files
+ r-assertive.numbers
+ r-assertive.reflection
+ r-assertive.sets
r-biocgenerics
r-biostrings
r-bsgenome
@@ -46,14 +49,15 @@ optdepends=(
r-txdb.mmusculus.ucsc.mm10.knowngene
)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('abf0ec2d4d8e9030e86a42449b5729a08e292040e4af711bcc72ca72bbdb508d')
+md5sums=('d0bbc847e39772348376d944c884290a')
+b2sums=('ed79977a043b0bf57b139d7f304568fd88d7bb7317c673e58f459908fb0330c545243798cdaec86fd56bdf3f0c2e67270e67e0f8f341d280b35b130d4d898be8')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: