summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-11-03 12:02:33 +0000
committerBioArchLinuxBot2023-11-03 12:02:33 +0000
commit5265732ed45581bf7007f6221b27dd3d0a346ed5 (patch)
tree48e7e611bbf6b5aae1a6af45ff61b3bb6e0018af
parentc1bef4d9b861d34aaddf65907e313a848f58eecd (diff)
downloadaur-5265732ed45581bf7007f6221b27dd3d0a346ed5.tar.gz
[lilac] updated to 1.24.0-1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD37
2 files changed, 29 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6c72a2fc933..4cc691befcbf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = r-multimir
pkgdesc = Integration of multiple microRNA-target databases with their disease and drug associations
- pkgver = 1.22.0
+ pkgver = 1.24.0
pkgrel = 1
url = https://bioconductor.org/packages/multiMiR
arch = any
license = MIT
- depends = r
+ checkdepends = r-testthat
depends = r-annotationdbi
depends = r-biocgenerics
depends = r-dplyr
@@ -18,7 +18,8 @@ pkgbase = r-multimir
optdepends = r-knitr
optdepends = r-rmarkdown
optdepends = r-testthat
- source = https://bioconductor.org/packages/release/bioc/src/contrib/multiMiR_1.22.0.tar.gz
- sha256sums = 5b7eca3f3b23dd9d6c86c90919037c44455a8ae126b690d41f427b2100e6e675
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/multiMiR_1.24.0.tar.gz
+ md5sums = 7102f312557b010d184bac5dea6e5009
+ sha256sums = 2574a7991c9552c84c8cd9c39ba4f5508d6e21870a0126da1ff855e96c82b157
pkgname = r-multimir
diff --git a/PKGBUILD b/PKGBUILD
index fc653cafacbd..792e2f69caec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
-# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=multiMiR
-_pkgver=1.22.0
+_pkgver=1.24.0
pkgname=r-${_pkgname,,}
-pkgver=1.22.0
+pkgver=${_pkgver//-/.}
pkgrel=1
-pkgdesc='Integration of multiple microRNA-target databases with their disease and drug associations'
-arch=('any')
+pkgdesc="Integration of multiple microRNA-target databases with their disease and drug associations"
+arch=(any)
url="https://bioconductor.org/packages/${_pkgname}"
-license=('MIT')
+license=(MIT)
depends=(
- r
r-annotationdbi
r-biocgenerics
r-dplyr
@@ -19,6 +19,9 @@ depends=(
r-tibble
r-xml
)
+checkdepends=(
+ r-testthat
+)
optdepends=(
r-biocstyle
r-edger
@@ -27,15 +30,23 @@ optdepends=(
r-testthat
)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('5b7eca3f3b23dd9d6c86c90919037c44455a8ae126b690d41f427b2100e6e675')
+md5sums=('7102f312557b010d184bac5dea6e5009')
+sha256sums=('2574a7991c9552c84c8cd9c39ba4f5508d6e21870a0126da1ff855e96c82b157')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
- install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ ln -s "/usr/lib/R/library/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
}
-# vim:set ts=2 sw=2 et: