summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 16:35:14 +0800
committerSukanka2022-06-06 16:35:14 +0800
commit709318eae768510ec230920722e5f0807766eab6 (patch)
treed770371dd33cd04e816ec5a057f0034cb2b9976c
downloadaur-709318eae768510ec230920722e5f0807766eab6.tar.gz
add r-multimir
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD41
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..618458960732
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = r-multimir
+ pkgdesc = Integration of multiple microRNA-target databases with their disease and drug associations
+ pkgver = 1.18.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/multiMiR
+ arch = any
+ license = MIT
+ depends = r
+ depends = r-annotationdbi
+ depends = r-biocgenerics
+ depends = r-dplyr
+ depends = r-purrr
+ depends = r-rcurl
+ depends = r-tibble
+ depends = r-xml
+ optdepends = r-biocstyle
+ optdepends = r-edger
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/multiMiR_1.18.0.tar.gz
+ sha256sums = ddf5855c24b24d7a6230a2e9a0ceaa8ac6e11ddb25ef052f0382e685761099f2
+
+pkgname = r-multimir
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e94d2fc9d8bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=multiMiR
+_pkgver=1.18.0
+pkgname=r-${_pkgname,,}
+pkgver=1.18.0
+pkgrel=1
+pkgdesc='Integration of multiple microRNA-target databases with their disease and drug associations'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('MIT')
+depends=(
+ r
+ r-annotationdbi
+ r-biocgenerics
+ r-dplyr
+ r-purrr
+ r-rcurl
+ r-tibble
+ r-xml
+)
+optdepends=(
+ r-biocstyle
+ r-edger
+ r-knitr
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('ddf5855c24b24d7a6230a2e9a0ceaa8ac6e11ddb25ef052f0382e685761099f2')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: