summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-11-27 13:27:45 +0200
committerPekka Ristola2023-11-27 13:27:45 +0200
commit6cef26edd85cb6714d17ec2914ef019587a398b6 (patch)
tree63591053f67b13eb36fe4a02e783ec3c7c3b8fd6
downloadaur-6cef26edd85cb6714d17ec2914ef019587a398b6.tar.gz
Version 1.0.0
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD63
2 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9ac2e8ffbe25
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+pkgbase = r-multirnaflow
+ pkgdesc = An R package for analysing RNA-seq raw counts with several biological conditions and different time points
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/MultiRNAflow
+ arch = any
+ license = GPL3
+ checkdepends = r-testthat
+ depends = r-biobase
+ depends = r-complexheatmap
+ depends = r-deseq2
+ depends = r-factoextra
+ depends = r-factominer
+ depends = r-ggalluvial
+ depends = r-ggplot2
+ depends = r-ggrepel
+ depends = r-ggsci
+ depends = r-gprofiler2
+ depends = r-mfuzz
+ depends = r-plot3d
+ depends = r-plot3drgl
+ depends = r-plyr
+ depends = r-rcolorbrewer
+ depends = r-reshape2
+ depends = r-rlang
+ depends = r-s4vectors
+ depends = r-scales
+ depends = r-summarizedexperiment
+ depends = r-upsetr
+ optdepends = r-biocgenerics
+ optdepends = r-biocstyle
+ optdepends = r-e1071
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/MultiRNAflow_1.0.0.tar.gz
+ md5sums = cefc109896f4cb34b4ee6a09ae966f42
+ sha256sums = 5e7e81f1e25b61abd3f2cdee0e39527ccd0b92a2029b3d88a148d905478378ed
+
+pkgname = r-multirnaflow
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1735da26afbb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=MultiRNAflow
+_pkgver=1.0.0
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="An R package for analysing RNA-seq raw counts with several biological conditions and different time points"
+arch=(any)
+url="https://bioconductor.org/packages/${_pkgname}"
+license=(GPL3)
+depends=(
+ r-biobase
+ r-complexheatmap
+ r-deseq2
+ r-factoextra
+ r-factominer
+ r-ggalluvial
+ r-ggplot2
+ r-ggrepel
+ r-ggsci
+ r-gprofiler2
+ r-mfuzz
+ r-plot3d
+ r-plot3drgl
+ r-plyr
+ r-rcolorbrewer
+ r-reshape2
+ r-rlang
+ r-s4vectors
+ r-scales
+ r-summarizedexperiment
+ r-upsetr
+)
+checkdepends=(
+ r-testthat
+)
+optdepends=(
+ r-biocgenerics
+ r-biocstyle
+ r-e1071
+ r-knitr
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('cefc109896f4cb34b4ee6a09ae966f42')
+sha256sums=('5e7e81f1e25b61abd3f2cdee0e39527ccd0b92a2029b3d88a148d905478378ed')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+}