summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2020-01-31 17:58:05 +0300
committerViktor Drobot2020-01-31 17:58:05 +0300
commit7ad8c04ec1cc1f057079940862cc8c6896fc41d3 (patch)
treea16af309444be420c8d7f1d0e1074a6d3e14e347
parent79ad5f2a5f5f17c896746f18a8460b7464865dd7 (diff)
downloadaur-7ad8c04ec1cc1f057079940862cc8c6896fc41d3.tar.gz
Fixed PKGBUILD
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 27 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a43946e3d0e8..0eed00aa7710 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,12 +2,14 @@ pkgbase = r-munsell
pkgdesc = Utilities for Using Munsell Colours
pkgver = 0.5.0
pkgrel = 1
- url = http://cran.r-project.org/web/packages/munsell/index.html
- arch = x86_64
- license = GPL3
+ url = https://cran.r-project.org/package=munsell
+ arch = any
+ license = MIT
depends = r
depends = r-colorspace
- source = http://cran.r-project.org/src/contrib/munsell_0.5.0.tar.gz
+ optdepends = r-ggplot2
+ optdepends = r-testthat
+ source = https://cran.r-project.org/src/contrib/munsell_0.5.0.tar.gz
md5sums = b287f380a958399cfa12f665232e7f34
pkgname = r-munsell
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 6ae0b18a1f6c..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-/pkg
-/src
-*.tar.gz
-*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 9e9260b1d070..3c7179a41eac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,29 @@
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Grey Christoforo <first name at last name dot net>
-pkgname=r-munsell
-_cran_name=munsell
-pkgver=0.5.0
+
+_cranname=munsell
+_cranver=0.5.0
+pkgname=r-${_cranname,,}
+pkgver=${_cranver//[:-]/.}
pkgrel=1
pkgdesc="Utilities for Using Munsell Colours"
-arch=('x86_64')
-url="http://cran.r-project.org/web/packages/${_cran_name}/index.html"
-license=('GPL3')
-depends=('r' 'r-colorspace')
-source=("http://cran.r-project.org/src/contrib/${_cran_name}_${pkgver}.tar.gz")
+arch=(any)
+url="https://cran.r-project.org/package=${_cranname}"
+license=(MIT)
+depends=(r r-colorspace)
+optdepends=(r-ggplot2 r-testthat)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
md5sums=('b287f380a958399cfa12f665232e7f34')
+build() {
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
+}
+
package() {
- mkdir -p $pkgdir/usr/lib/R/library
- cd $srcdir
+ cd "${srcdir}"
- R CMD INSTALL -l $pkgdir/usr/lib/R/library ./${_cran_name}
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
}