summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-11-25 08:34:44 +0200
committerPekka Ristola2023-11-25 08:34:44 +0200
commitfb3de5fa27b4d6f89f5b0bbe85a6b4d08ebf1c34 (patch)
tree40fc312d05c3364c01574c0740a6c50a8aabc4e2
downloadaur-fb3de5fa27b4d6f89f5b0bbe85a6b4d08ebf1c34.tar.gz
Version 0.2.8
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD42
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..39f71b7c572e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = r-mvnfast
+ pkgdesc = Fast Multivariate Normal and Student's t Methods
+ pkgver = 0.2.8
+ pkgrel = 1
+ url = https://cran.r-project.org/package=mvnfast
+ arch = x86_64
+ license = GPL
+ makedepends = r-bh
+ makedepends = r-rcpparmadillo
+ depends = blas
+ depends = lapack
+ depends = r-rcpp
+ optdepends = r-knitr
+ optdepends = r-microbenchmark
+ optdepends = r-mvtnorm
+ optdepends = r-plyr
+ optdepends = r-rhpcblasctl
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://cran.r-project.org/src/contrib/mvnfast_0.2.8.tar.gz
+ md5sums = 7f86b01f428f34145a2fd143b441e9bf
+ sha256sums = 8871e0ce54b87afc556fd94ca77c3db72dcbb8c245558287e0fe342e30eec9a0
+
+pkgname = r-mvnfast
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e1b191a4af71
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=mvnfast
+_pkgver=0.2.8
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="Fast Multivariate Normal and Student's t Methods"
+arch=(x86_64)
+url="https://cran.r-project.org/package=${_pkgname}"
+license=(GPL)
+depends=(
+ blas
+ lapack
+ r-rcpp
+)
+makedepends=(
+ r-bh
+ r-rcpparmadillo
+)
+optdepends=(
+ r-knitr
+ r-microbenchmark
+ r-mvtnorm
+ r-plyr
+ r-rhpcblasctl
+ r-rmarkdown
+ r-testthat
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('7f86b01f428f34145a2fd143b441e9bf')
+sha256sums=('8871e0ce54b87afc556fd94ca77c3db72dcbb8c245558287e0fe342e30eec9a0')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+}