summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 16:52:14 +0800
committerSukanka2022-06-06 16:52:14 +0800
commitef9f6b0a1189e7817879725a49fad55a98016083 (patch)
tree0ff1499175e13376bee0b83d109fed3786c6b616
downloadaur-ef9f6b0a1189e7817879725a49fad55a98016083.tar.gz
add r-ncmisc
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..568c612a4c7d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = r-ncmisc
+ pkgdesc = Miscellaneous Functions for Creating Adaptive Functions and Scripts
+ pkgver = 1.1.6
+ pkgrel = 4
+ url = https://cran.r-project.org/package=NCmisc
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-proftools
+ optdepends = r-kernsmooth
+ optdepends = r-matrix
+ source = https://cran.r-project.org/src/contrib/NCmisc_1.1.6.tar.gz
+ sha256sums = 2aa85997d5ec2222e610604022684c004a4925241761d9a0104919f1cf3a8c79
+
+pkgname = r-ncmisc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9fa1d9eb5b22
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=NCmisc
+_pkgver=1.1.6
+pkgname=r-${_pkgname,,}
+pkgver=1.1.6
+pkgrel=4
+pkgdesc='Miscellaneous Functions for Creating Adaptive Functions and Scripts'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-proftools
+)
+optdepends=(
+ r-kernsmooth
+ r-matrix
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('2aa85997d5ec2222e610604022684c004a4925241761d9a0104919f1cf3a8c79')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: