summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaekyung Kim2019-07-12 06:16:18 +0900
committerTaekyung Kim2019-07-12 06:16:18 +0900
commit7d95d06f9a5600c86175e59611518c920f5178a9 (patch)
tree213574b181fd6d2e3ce399df592716b3f4cfbeb4
downloadaur-7d95d06f9a5600c86175e59611518c920f5178a9.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..39cfe4863981
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = r-nloptr
+ pkgdesc = R Interface to NLopt
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = https://cran.r-project.org/package=nloptr
+ arch = any
+ license = LGPL3
+ depends = r
+ optdepends = r-testthat>=0.8.1
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-inline>=0.3.14
+ source = https://cran.r-project.org/src/contrib/nloptr_1.2.1.tar.gz
+ md5sums = 3c475302f105dfe6a0e495ccdf4d78b1
+
+pkgname = r-nloptr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a489f0ea062
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Taekyung Kim <Taekyung.Kim.Maths@gmail.com>
+
+_cranname=nloptr
+_cranver=1.2.1
+_pkgtar=${_cranname}_${_cranver}.tar.gz
+pkgname=r-nloptr
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="R Interface to NLopt"
+arch=('any')
+url="https://cran.r-project.org/package=${_cranname}"
+license=('LGPL3')
+depends=('r')
+optdepends=('r-testthat>=0.8.1' 'r-knitr' 'r-rmarkdown' 'r-inline>=0.3.14')
+makedepends=()
+source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
+md5sums=('3c475302f105dfe6a0e495ccdf4d78b1')
+
+build(){
+ R CMD INSTALL "${_pkgtar}" -l "$srcdir"
+}
+package() {
+ install -dm0755 "$pkgdir"/usr/lib/R/library
+ cp -a --no-preserve=ownership "$_cranname" "$pkgdir"/usr/lib/R/library
+}
+
+