summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2020-03-10 00:29:39 +0300
committerViktor Drobot2020-03-10 00:29:39 +0300
commit8cff3a63910429b0b4b3088ebb34413f0795f040 (patch)
tree5562690d60387e413c351e023d2c3af7b5d7c9b1
parent7d95d06f9a5600c86175e59611518c920f5178a9 (diff)
downloadaur-8cff3a63910429b0b4b3088ebb34413f0795f040.tar.gz
Fixed PKGBUILD
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD37
2 files changed, 28 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39cfe4863981..45b3bbe19fab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = r-nloptr
pkgdesc = R Interface to NLopt
- pkgver = 1.2.1
+ pkgver = 1.2.2
pkgrel = 1
url = https://cran.r-project.org/package=nloptr
- arch = any
+ arch = i686
+ arch = x86_64
license = LGPL3
+ makedepends = gcc
depends = r
- optdepends = r-testthat>=0.8.1
+ optdepends = r-testthat
optdepends = r-knitr
optdepends = r-rmarkdown
- optdepends = r-inline>=0.3.14
- source = https://cran.r-project.org/src/contrib/nloptr_1.2.1.tar.gz
- md5sums = 3c475302f105dfe6a0e495ccdf4d78b1
+ optdepends = r-inline
+ source = https://cran.r-project.org/src/contrib/nloptr_1.2.2.tar.gz
+ md5sums = 47590eabd1beb757867b34f068950ca5
pkgname = r-nloptr
diff --git a/PKGBUILD b/PKGBUILD
index 3a489f0ea062..50f1f507cd68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,30 @@
-# Maintainer: Taekyung Kim <Taekyung.Kim.Maths@gmail.com>
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Contributor: Taekyung Kim <Taekyung.Kim.Maths@gmail.com>
_cranname=nloptr
-_cranver=1.2.1
-_pkgtar=${_cranname}_${_cranver}.tar.gz
-pkgname=r-nloptr
+_cranver=1.2.2
+pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
pkgrel=1
pkgdesc="R Interface to NLopt"
-arch=('any')
+arch=(i686 x86_64)
url="https://cran.r-project.org/package=${_cranname}"
-license=('LGPL3')
-depends=('r')
-optdepends=('r-testthat>=0.8.1' 'r-knitr' 'r-rmarkdown' 'r-inline>=0.3.14')
-makedepends=()
-source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
-md5sums=('3c475302f105dfe6a0e495ccdf4d78b1')
+license=(LGPL3)
+depends=(r)
+makedepends=(gcc)
+optdepends=(r-testthat r-knitr r-rmarkdown r-inline)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('47590eabd1beb757867b34f068950ca5')
-build(){
- R CMD INSTALL "${_pkgtar}" -l "$srcdir"
-}
-package() {
- install -dm0755 "$pkgdir"/usr/lib/R/library
- cp -a --no-preserve=ownership "$_cranname" "$pkgdir"/usr/lib/R/library
+build() {
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
}
+package() {
+ cd "${srcdir}"
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+}