summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 17:31:46 +0800
committerSukanka2022-06-06 17:31:46 +0800
commite833c6ad1136a969d1941328a3a50f04847129ad (patch)
tree2ead7e50faeadab3f8aa3f1bc370084f5017cb9f
downloadaur-e833c6ad1136a969d1941328a3a50f04847129ad.tar.gz
add r-opencyto
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD58
2 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eab29c31bbd0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+pkgbase = r-opencyto
+ pkgdesc = Hierarchical Gating Pipeline for flow cytometry data
+ pkgver = 2.8.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/openCyto
+ arch = x86_64
+ license = custom
+ depends = r
+ depends = r-biobase
+ depends = r-biocgenerics
+ depends = r-clue
+ depends = r-data.table
+ depends = r-flowclust
+ depends = r-flowcore
+ depends = r-flowstats
+ depends = r-flowviz
+ depends = r-flowworkspace
+ depends = r-graph
+ depends = r-gtools
+ depends = r-ks
+ depends = r-ncdfflow
+ depends = r-plyr
+ depends = r-r.utils
+ depends = r-rbgl
+ depends = r-rcolorbrewer
+ depends = r-rcpp
+ depends = r-rrcov
+ optdepends = r-cytoml
+ optdepends = r-flowworkspacedata
+ optdepends = r-ggcyto
+ optdepends = r-knitr
+ optdepends = r-markdown
+ optdepends = r-parallel
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ optdepends = r-tools
+ optdepends = r-utils
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/openCyto_2.8.0.tar.gz
+ sha256sums = 3ee8bc6bdd7273fe41d6ca7167dd1666f5f2ad9ee5b3e53c97e038095476e5db
+
+pkgname = r-opencyto
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b076854b86f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=openCyto
+_pkgver=2.8.0
+pkgname=r-${_pkgname,,}
+pkgver=2.8.0
+pkgrel=1
+pkgdesc='Hierarchical Gating Pipeline for flow cytometry data'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('custom')
+depends=(
+ r
+ r-biobase
+ r-biocgenerics
+ r-clue
+ r-data.table
+ r-flowclust
+ r-flowcore
+ r-flowstats
+ r-flowviz
+ r-flowworkspace
+ r-graph
+ r-gtools
+ r-ks
+ r-ncdfflow
+ r-plyr
+ r-r.utils
+ r-rbgl
+ r-rcolorbrewer
+ r-rcpp
+ r-rrcov
+)
+optdepends=(
+ r-cytoml
+ r-flowworkspacedata
+ r-ggcyto
+ r-knitr
+ r-markdown
+ r-parallel
+ r-rmarkdown
+ r-testthat
+ r-tools
+ r-utils
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('3ee8bc6bdd7273fe41d6ca7167dd1666f5f2ad9ee5b3e53c97e038095476e5db')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: