summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-08-15 00:01:30 +0000
committerBioArchLinuxBot2023-08-15 00:01:30 +0000
commit250680af8a9c0bdf32b6d2f1fe6f3dea50baa8fe (patch)
tree4af9f479ac0bd2a06ca77487504a3a8327276fdc
parent37e085b7aa18af1209a5fa7246ad5ed6d42a99a4 (diff)
downloadaur-250680af8a9c0bdf32b6d2f1fe6f3dea50baa8fe.tar.gz
[lilac] updated to 2023.8.13-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 25 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df1e728ec3b6..ae240536cd64 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,27 @@
pkgbase = r-optimx
pkgdesc = Expanded Replacement and Extension of the 'optim' Function
- pkgver = 2022.4.30
+ pkgver = 2023.8.13
pkgrel = 1
url = https://cran.r-project.org/package=optimx
arch = any
- license = GPL
- depends = r
+ license = GPL2
+ depends = r-nloptr
depends = r-numderiv
+ depends = r-pracma
optdepends = r-bb
optdepends = r-dfoptim
optdepends = r-knitr
optdepends = r-lbfgs
optdepends = r-lbfgsb3c
+ optdepends = r-marqlevalg
optdepends = r-minqa
optdepends = r-rmarkdown
optdepends = r-setrng
optdepends = r-subplex
+ optdepends = r-testthat
optdepends = r-ucminf
- source = https://cran.r-project.org/src/contrib/optimx_2022-4.30.tar.gz
- sha256sums = ebe9887a22296cf4b2db07981aaa1f898bf7c17fb61a4b398c228d4077d0b410
+ source = https://cran.r-project.org/src/contrib/optimx_2023-8.13.tar.gz
+ md5sums = f936dff9a2dba66f63876b463957ea9f
+ sha256sums = 163956791eb3b09f6a9a1c8e2ccb7f44fe8e02124fc2a732701be9070a818803
pkgname = r-optimx
diff --git a/PKGBUILD b/PKGBUILD
index dc32edfda3d1..cb9e7baac10e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
-# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=optimx
-_pkgver=2022-4.30
+_pkgver=2023-8.13
pkgname=r-${_pkgname,,}
-pkgver=2022.4.30
+pkgver=${_pkgver//-/.}
pkgrel=1
pkgdesc="Expanded Replacement and Extension of the 'optim' Function"
-arch=('any')
+arch=(any)
url="https://cran.r-project.org/package=${_pkgname}"
-license=('GPL')
+license=(GPL2)
depends=(
- r
+ r-nloptr
r-numderiv
+ r-pracma
)
optdepends=(
r-bb
@@ -19,21 +21,24 @@ optdepends=(
r-knitr
r-lbfgs
r-lbfgsb3c
+ r-marqlevalg
r-minqa
r-rmarkdown
r-setrng
r-subplex
+ r-testthat
r-ucminf
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('ebe9887a22296cf4b2db07981aaa1f898bf7c17fb61a4b398c228d4077d0b410')
+md5sums=('f936dff9a2dba66f63876b463957ea9f')
+sha256sums=('163956791eb3b09f6a9a1c8e2ccb7f44fe8e02124fc2a732701be9070a818803')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: