summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2021-09-04 00:24:45 +0300
committerViktor Drobot2021-09-04 00:24:45 +0300
commitd3bee7663d862fe7dea545c450b94d66c3208f9f (patch)
tree5efc8fdb993d87cff8f23fc2eb21073600b163a5
downloadaur-d3bee7663d862fe7dea545c450b94d66c3208f9f.tar.gz
First release
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..46c049d63b92
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = r-parallelly
+ pkgdesc = Enhancing the 'parallel' Package
+ pkgver = 1.27.0
+ pkgrel = 1
+ url = https://cran.r-project.org/package=parallelly
+ arch = any
+ license = LGPL2.1
+ license = LGPL3
+ depends = r
+ source = https://cran.r-project.org/src/contrib/parallelly_1.27.0.tar.gz
+ sha256sums = 6355dc4830894234f1623c6a21693bb0f56a7cab9d362312d14717ed184fbef7
+
+pkgname = r-parallelly
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..379cc14e3439
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+
+_cranname=parallelly
+_cranver=1.27.0
+pkgname=r-${_cranname,,}
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="Enhancing the 'parallel' Package"
+arch=(any)
+url="https://cran.r-project.org/package=${_cranname}"
+license=(LGPL2.1 LGPL3)
+depends=(r)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+sha256sums=('6355dc4830894234f1623c6a21693bb0f56a7cab9d362312d14717ed184fbef7')
+
+build() {
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+}