summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-11-27 13:50:00 +0200
committerPekka Ristola2023-11-27 13:50:00 +0200
commit8961fb332b3a612ac1a274b24a4cdc0317aaa595 (patch)
tree001b5750a8c8ee4b7700e48f137bf443fdaa64d6
downloadaur-8961fb332b3a612ac1a274b24a4cdc0317aaa595.tar.gz
Version 1.0.0
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD48
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..55d6fd69646e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = r-partcnv
+ pkgdesc = Infer locally aneuploid cells using single cell RNA-seq data
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/partCNV
+ arch = any
+ license = GPL2
+ checkdepends = r-testthat
+ depends = r-annotationhub
+ depends = r-data.table
+ depends = r-depmixs4
+ depends = r-genomicranges
+ depends = r-magrittr
+ depends = r-seurat
+ depends = r-singlecellexperiment
+ optdepends = r-biocstyle
+ optdepends = r-iranges
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/partCNV_1.0.0.tar.gz
+ md5sums = e004f2129cbb1fe1e84e33cf223c06f6
+ sha256sums = 4a948e65fe1f20118f9f5642e23fa35b92bfae680b5da1762084e88e187d8a95
+
+pkgname = r-partcnv
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b4b157e16210
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=partCNV
+_pkgver=1.0.0
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="Infer locally aneuploid cells using single cell RNA-seq data"
+arch=(any)
+url="https://bioconductor.org/packages/${_pkgname}"
+license=(GPL2)
+depends=(
+ r-annotationhub
+ r-data.table
+ r-depmixs4
+ r-genomicranges
+ r-magrittr
+ r-seurat
+ r-singlecellexperiment
+)
+checkdepends=(
+ r-testthat
+)
+optdepends=(
+ r-biocstyle
+ r-iranges
+ r-knitr
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('e004f2129cbb1fe1e84e33cf223c06f6')
+sha256sums=('4a948e65fe1f20118f9f5642e23fa35b92bfae680b5da1762084e88e187d8a95')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+}