summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 18:00:18 +0800
committerSukanka2022-06-06 18:00:18 +0800
commite7dee7a13f4350a7fc36a0b3a13b96686cca8c54 (patch)
tree43892b4edc245a8a5c67323f2a16606735d07249
downloadaur-e7dee7a13f4350a7fc36a0b3a13b96686cca8c54.tar.gz
add r-pasilla
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..48889a958422
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = r-pasilla
+ pkgdesc = Data package with per-exon and per-gene read counts of RNA-seq samples of Pasilla knock-down by Brooks et al., Genome Research 2011.
+ pkgver = 1.24.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/pasilla
+ arch = any
+ license = LGPL
+ depends = r
+ depends = r-dexseq
+ optdepends = r-biocstyle
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ source = https://bioconductor.org/packages/release/data/experiment/src/contrib/pasilla_1.24.0.tar.gz
+ sha256sums = 2b7a79ec31df14c8b3d7244d7f17a074c9acba964fbfa2715b334fb1eb815def
+
+pkgname = r-pasilla
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f9fd0084252
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=pasilla
+_pkgver=1.24.0
+pkgname=r-${_pkgname,,}
+pkgver=1.24.0
+pkgrel=1
+pkgdesc='Data package with per-exon and per-gene read counts of RNA-seq samples of Pasilla knock-down by Brooks et al., Genome Research 2011.'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('LGPL')
+depends=(
+ r
+ r-dexseq
+)
+optdepends=(
+ r-biocstyle
+ r-knitr
+ r-rmarkdown
+)
+source=("https://bioconductor.org/packages/release/data/experiment/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('2b7a79ec31df14c8b3d7244d7f17a074c9acba964fbfa2715b334fb1eb815def')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: