summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 18:03:03 +0800
committerSukanka2022-06-06 18:03:03 +0800
commit8fa46cfbd8f44e2782a78cb1c009dbc51252cb3f (patch)
tree7213efe825ddf28b883fecf22c11aa6782332f35
downloadaur-8fa46cfbd8f44e2782a78cb1c009dbc51252cb3f.tar.gz
add r-pathostat
-rw-r--r--.SRCINFO43
-rw-r--r--PKGBUILD59
2 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..251dce25d597
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,43 @@
+pkgbase = r-pathostat
+ pkgdesc = PathoStat Statistical Microbiome Analysis Package
+ pkgver = 1.22.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/PathoStat
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-ape
+ depends = r-biocstyle
+ depends = r-complexheatmap
+ depends = r-corpcor
+ depends = r-deseq2
+ depends = r-devtools
+ depends = r-dplyr
+ depends = r-dt
+ depends = r-edger
+ depends = r-ggplot2
+ depends = r-glmnet
+ depends = r-gmodels
+ depends = r-knitr
+ depends = r-limma
+ depends = r-matrixstats
+ depends = r-phyloseq
+ depends = r-plotly
+ depends = r-plyr
+ depends = r-rcolorbrewer
+ depends = r-rentrez
+ depends = r-reshape2
+ depends = r-rocr
+ depends = r-scales
+ depends = r-shiny
+ depends = r-shinyjs
+ depends = r-tidyr
+ depends = r-vegan
+ depends = r-webshot
+ depends = r-xml
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/PathoStat_1.22.0.tar.gz
+ sha256sums = e9d75278b669f001b00a9cb9f8e1650c40c3bcbcf8eda83693a0f0cc6cde01b8
+
+pkgname = r-pathostat
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f6fb2b0ea0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=PathoStat
+_pkgver=1.22.0
+pkgname=r-${_pkgname,,}
+pkgver=1.22.0
+pkgrel=1
+pkgdesc='PathoStat Statistical Microbiome Analysis Package'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-ape
+ r-biocstyle
+ r-complexheatmap
+ r-corpcor
+ r-deseq2
+ r-devtools
+ r-dplyr
+ r-dt
+ r-edger
+ r-ggplot2
+ r-glmnet
+ r-gmodels
+ r-knitr
+ r-limma
+ r-matrixstats
+ r-phyloseq
+ r-plotly
+ r-plyr
+ r-rcolorbrewer
+ r-rentrez
+ r-reshape2
+ r-rocr
+ r-scales
+ r-shiny
+ r-shinyjs
+ r-tidyr
+ r-vegan
+ r-webshot
+ r-xml
+)
+optdepends=(
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('e9d75278b669f001b00a9cb9f8e1650c40c3bcbcf8eda83693a0f0cc6cde01b8')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: