summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 18:09:03 +0800
committerSukanka2022-06-06 18:09:03 +0800
commit99fbe2043e3e3fe8d6851e56374cbfb1da1c6224 (patch)
treed5c9d1655071231f5fc4f9022bce4e8902d2bf73
downloadaur-99fbe2043e3e3fe8d6851e56374cbfb1da1c6224.tar.gz
add r-pcxn
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a2e6eb18f17
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = r-pcxn
+ pkgdesc = Exploring, analyzing and visualizing functions utilizing the pcxnData package
+ pkgver = 2.18.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/pcxn
+ arch = any
+ license = MIT
+ depends = r
+ depends = r-pcxndata
+ depends = r-pheatmap
+ optdepends = r-annotate
+ optdepends = r-igraph
+ optdepends = r-org.hs.eg.db
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/pcxn_2.18.0.tar.gz
+ sha256sums = 88fb13ddd6834b6523973fb96370ef31a109d5e4bf2e6f18b467e7f52c5a8323
+
+pkgname = r-pcxn
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3f830bb47d75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=pcxn
+_pkgver=2.18.0
+pkgname=r-${_pkgname,,}
+pkgver=2.18.0
+pkgrel=1
+pkgdesc='Exploring, analyzing and visualizing functions utilizing the pcxnData package'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('MIT')
+depends=(
+ r
+ r-pcxndata
+ r-pheatmap
+)
+optdepends=(
+ r-annotate
+ r-igraph
+ r-org.hs.eg.db
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('88fb13ddd6834b6523973fb96370ef31a109d5e4bf2e6f18b467e7f52c5a8323')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: