summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 18:09:27 +0800
committerSukanka2022-06-06 18:09:27 +0800
commit6e8f8b5d5248ae857f843c5345dad29a1c646930 (patch)
tree21b7680643e585aa5e788fd23c04577bc6f4be2b
downloadaur-6e8f8b5d5248ae857f843c5345dad29a1c646930.tar.gz
add r-pcxndata
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e163b8106ef9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = r-pcxndata
+ pkgdesc = Correlation coefficients and p values between pre-defined pathway/gene sets
+ pkgver = 2.18.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/pcxnData
+ arch = any
+ license = MIT
+ depends = r
+ optdepends = r-pcxn
+ source = https://bioconductor.org/packages/release/data/experiment/src/contrib/pcxnData_2.18.0.tar.gz
+ sha256sums = 902c1732c293e4a205089cc6518efe12ed549e33b0535e5789f8e4c3463a8cbf
+
+pkgname = r-pcxndata
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5f0fb7e0ea5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=pcxnData
+_pkgver=2.18.0
+pkgname=r-${_pkgname,,}
+pkgver=2.18.0
+pkgrel=1
+pkgdesc='Correlation coefficients and p values between pre-defined pathway/gene sets'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('MIT')
+depends=(
+ r
+)
+optdepends=(
+ r-pcxn
+)
+source=("https://bioconductor.org/packages/release/data/experiment/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('902c1732c293e4a205089cc6518efe12ed549e33b0535e5789f8e4c3463a8cbf')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: