summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 18:17:48 +0800
committerSukanka2022-06-06 18:17:48 +0800
commit3b9e07533f838bc6bfbdd1573c5213195f77025e (patch)
treed541dbc2144f766d2a7cd145de548ff561febfcd
downloadaur-3b9e07533f838bc6bfbdd1573c5213195f77025e.tar.gz
add r-perturbatr
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD48
2 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a6c9e29e2d75
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = r-perturbatr
+ pkgdesc = Statistical Analysis of High-Throughput Genetic Perturbation Screens
+ pkgver = 1.13.0
+ pkgrel = 2
+ url = https://bioconductor.org/packages/perturbatr
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-assertthat
+ depends = r-diffusr
+ depends = r-doparallel
+ depends = r-dplyr
+ depends = r-foreach
+ depends = r-formula.tools
+ depends = r-ggplot2
+ depends = r-igraph
+ depends = r-lazyeval
+ depends = r-lme4
+ depends = r-magrittr
+ depends = r-rlang
+ depends = r-scales
+ depends = r-tibble
+ depends = r-tidyr
+ optdepends = r-biocstyle
+ optdepends = r-knitr
+ optdepends = r-lintr
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/perturbatr_1.13.0.tar.gz
+ sha256sums = 61784a30329cbce1505cd7371ffb61a458d5d8b7e20b7d42b22b42413243536b
+
+pkgname = r-perturbatr
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94d69d5d251b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=perturbatr
+_pkgver=1.13.0
+pkgname=r-${_pkgname,,}
+pkgver=1.13.0
+pkgrel=2
+pkgdesc='Statistical Analysis of High-Throughput Genetic Perturbation Screens'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-assertthat
+ r-diffusr
+ r-doparallel
+ r-dplyr
+ r-foreach
+ r-formula.tools
+ r-ggplot2
+ r-igraph
+ r-lazyeval
+ r-lme4
+ r-magrittr
+ r-rlang
+ r-scales
+ r-tibble
+ r-tidyr
+)
+optdepends=(
+ r-biocstyle
+ r-knitr
+ r-lintr
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('61784a30329cbce1505cd7371ffb61a458d5d8b7e20b7d42b22b42413243536b')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: